diff mbox series

[bug#66263,10/23] gnu: Add binutils-cross-avr.

Message ID 20230929091627.7820-10-jean@foundationdevices.com
State New
Headers show
Series guix: Add avr as a platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Sept. 29, 2023, 9:16 a.m. UTC
* gnu/packages/cross-toolchain.scm (binutils-cross-avr): New variable.
---
 gnu/packages/cross-toolchain.scm | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Maxim Cournoyer Oct. 5, 2023, 2:46 p.m. UTC | #1
Hi,

Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> writes:

> * gnu/packages/cross-toolchain.scm (binutils-cross-avr): New variable.
> ---
>  gnu/packages/cross-toolchain.scm | 5 +++++
>  1 file changed, 5 insertions(+)
>
> diff --git a/gnu/packages/cross-toolchain.scm b/gnu/packages/cross-toolchain.scm
> index 0062d043a0..5617959851 100644
> --- a/gnu/packages/cross-toolchain.scm
> +++ b/gnu/packages/cross-toolchain.scm
> @@ -56,3 +56,8 @@ (define* (make-cross-gcc-toolchain target
>  libc (headers and binaries), and Binutils.  GCC is the GNU Compiler
>  Collection.")
>      (home-page "https://gcc.gnu.org/")))
> +
> +;;; Cross binutils:
> +
> +(define-public binutils-cross-avr
> +  (cross-binutils "avr"))

Since this module *uses* the cross* procedures that are likely to create
top level cycles, it should be stressed after the imports near the top
in a ;;; Commentary:  comment block that this module exists solely to
provide a convenient way to install the cross toolchains as packages,
and should NOT be imported by any other module to avoid introducing
module cycles.
diff mbox series

Patch

diff --git a/gnu/packages/cross-toolchain.scm b/gnu/packages/cross-toolchain.scm
index 0062d043a0..5617959851 100644
--- a/gnu/packages/cross-toolchain.scm
+++ b/gnu/packages/cross-toolchain.scm
@@ -56,3 +56,8 @@  (define* (make-cross-gcc-toolchain target
 libc (headers and binaries), and Binutils.  GCC is the GNU Compiler
 Collection.")
     (home-page "https://gcc.gnu.org/")))
+
+;;; Cross binutils:
+
+(define-public binutils-cross-avr
+  (cross-binutils "avr"))