diff mbox series

[bug#66263,03/23] gnu: Add avr platform.

Message ID 20230929091627.7820-3-jean@foundationdevices.com
State New
Headers show
Series guix: Add avr as a platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Sept. 29, 2023, 9:16 a.m. UTC
* Makefile.am (MODULES): Add avr platform module.

* doc/guix.texi: Add documentation for avr platform.

* guix/platforms/avr.scm (avr): New variable.
---
 Makefile.am            |  1 +
 doc/guix.texi          |  6 ++++++
 guix/platforms/avr.scm | 29 +++++++++++++++++++++++++++++
 3 files changed, 36 insertions(+)
 create mode 100644 guix/platforms/avr.scm
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index 8924974e8a..c11a1c538d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -136,6 +136,7 @@  MODULES =					\
   guix/ipfs.scm					\
   guix/platform.scm                             \
   guix/platforms/arm.scm                        \
+  guix/platforms/avr.scm                        \
   guix/platforms/mips.scm                       \
   guix/platforms/powerpc.scm                    \
   guix/platforms/riscv.scm                      \
diff --git a/doc/guix.texi b/doc/guix.texi
index 46591b2f64..70cde9c53c 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -16665,6 +16665,7 @@  The available targets are:
 
    - aarch64-linux-gnu
    - arm-linux-gnueabihf
+   - avr
    - i586-pc-gnu
    - i686-linux-gnu
    - i686-w64-mingw32
@@ -45332,6 +45333,11 @@  Platform targeting x86 CPU running GNU/Hurd (also referred to as
 ``GNU'').
 @end defvar
 
+@defvar avr
+Platform targeting AVR CPUs without an operating system, with run-time support
+from AVR Libc.
+@end defvar
+
 @node System Images
 @chapter Creating System Images
 
diff --git a/guix/platforms/avr.scm b/guix/platforms/avr.scm
new file mode 100644
index 0000000000..b6ca6e4a10
--- /dev/null
+++ b/guix/platforms/avr.scm
@@ -0,0 +1,29 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix platforms avr)
+  #:use-module (guix platform)
+  #:use-module (guix records)
+  #:export (avr))
+
+(define avr
+  (platform
+   (target "avr")
+   (system #f)
+   (glibc-dynamic-linker #f)))
+