diff mbox series

[bug#66263,13/23] gnu: cross-libc: Add AVR Libc case.

Message ID 20230929091627.7820-13-jean@foundationdevices.com
State New
Headers show
Series guix: Add avr as a platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Sept. 29, 2023, 9:16 a.m. UTC
* gnu/packages/cross-base.scm (cross-libc): Handle the AVR target case
  and return AVR Libc package.
---
 gnu/packages/cross-base.scm | 3 +++
 1 file changed, 3 insertions(+)

Comments

Maxim Cournoyer Oct. 5, 2023, 2:52 p.m. UTC | #1
Hello,

Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> writes:

> * gnu/packages/cross-base.scm (cross-libc): Handle the AVR target case
>   and return AVR Libc package.

nitpick: hanging indent :-).  Otherwise, LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index ec7ca2186d..fc21e7c4fd 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -28,6 +28,7 @@ 
 
 (define-module (gnu packages cross-base)
   #:use-module (gnu packages)
+  #:use-module (gnu packages avr)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages base)
   #:use-module (gnu packages linux)
@@ -622,6 +623,8 @@  (define* (cross-libc* target
   "Return LIBC cross-built for TARGET, a GNU triplet. Use XGCC and XBINUTILS
 and the cross tool chain."
   (match target
+   ((? target-avr?)
+    (make-avr-libc #:xgcc xgcc #:xbinutils xbinutils))
    ((? target-mingw?)
     (let ((machine (substring target 0 (string-index target #\-))))
       (make-mingw-w64 machine