diff mbox series

[bug#59870,09/12] gnu: Add r-gunifrac.

Message ID 20221207051837.10970-9-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59870,01/12] gnu: Add r-statip. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 7, 2022, 5:18 a.m. UTC
* gnu/packages/cran.scm (r-gunifrac): New variable.
---
 gnu/packages/cran.scm | 44 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 415098aed3..646737ea31 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -667,6 +667,50 @@  (define-public r-guix-install
 repositories, replacing the need for installation via @code{devtools}.")
     (license license:gpl3+)))
 
+(define-public r-gunifrac
+  (package
+    (name "r-gunifrac")
+    (version "1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "GUniFrac" version))
+              (sha256
+               (base32
+                "13qb5fw9km6p5x8li9x3liqbh833wf2v73npj8jl3msplzfk82vp"))))
+    (properties `((upstream-name . "GUniFrac")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-ape
+           r-dirmult
+           r-foreach
+           r-ggplot2
+           r-ggrepel
+           r-mass
+           r-matrix
+           r-matrixstats
+           r-modeest
+           r-rcpp
+           r-rmutil
+           r-statmod
+           r-vegan))
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=GUniFrac")
+    (synopsis
+     "Generalized UniFrac distances and methods for microbiome data analysis")
+    (description
+     "This package provides a suite of methods for powerful and robust microbiome
+data analysis, including data normalization, data simulation, community-level
+association testing and differential abundance analysis.  It implements generalized
+UniFrac distances, Geometric Mean of Pairwise Ratios (GMPR) normalization,
+semiparametric data simulator, distance-based statistical methods, and feature-
+based statistical methods.  The distance-based statistical methods include three
+extensions of PERMANOVA: (1) PERMANOVA using the Freedman-Lane permutation scheme,
+(2) PERMANOVA omnibus test using multiple matrices, and (3) analytical approach
+to approximating PERMANOVA p-value.  Feature-based statistical methods include
+linear model-based methods for differential abundance analysis of zero-inflated
+high-dimensional compositional data.")
+    (license license:gpl3)))
+
 (define-public r-ids
   (package
     (name "r-ids")