diff mbox series

[bug#59870,11/12] gnu: Add r-plotroc.

Message ID 20221207051837.10970-11-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59870,01/12] gnu: Add r-statip. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 7, 2022, 5:18 a.m. UTC
* gnu/packages/cran.scm (r-plotroc): New variable.
---
 gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b61ee1c2dc..87c22810d5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21844,6 +21844,36 @@  (define-public r-plot3d
 includes data sets from oceanography.")
     (license license:gpl3+)))
 
+(define-public r-plotroc
+  (package
+    (name "r-plotroc")
+    (version "2.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "plotROC" version))
+              (sha256
+               (base32
+                "0kaz9hrimi9gi7cf7flag9kc9yrg5fdyylqa5hn53x4dy8vhj37g"))))
+    (properties `((upstream-name . "plotROC")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-ggplot2
+           r-gridsvg
+           r-plyr
+           r-rlang
+           r-shiny))
+    (native-inputs (list r-knitr))
+    (home-page "https://sachsmc.github.io/plotROC/")
+    (synopsis "Generating useful receiver operating characteristic curve charts")
+    (description
+     "This package generates @acronym{ROC, receiver operating characteristic}
+plots.  Most ROC curve plots obscure the cutoff values and inhibit interpretation
+and comparison of multiple curves.  This attempts to address those shortcomings
+by providing plotting and interactive tools.  Functions are provided to generate
+an interactive ROC curve plot for web use, and print versions.  A Shiny application
+implementing the functions is also included.")
+    (license license:expat)))
+
 (define-public r-ggfortify
   (package
     (name "r-ggfortify")