diff mbox series

[bug#59870,03/12] gnu: Add r-stable.

Message ID 20221207051837.10970-3-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59870,01/12] gnu: Add r-statip. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 7, 2022, 5:18 a.m. UTC
* gnu/packages/cran.scm (r-stable): New variable.
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 792fcf1a7d..b773c6aeb9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6452,6 +6452,28 @@  (define-public r-corrplot
     ;; Any version of the GPL
     (license license:gpl2+)))
 
+(define-public r-stable
+  (package
+    (name "r-stable")
+    (version "1.1.6")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "stable" version))
+              (sha256
+               (base32
+                "194xsa291v5f0jya1c3aigbclg8cci427ffpb8brxamm6n57hf12"))))
+    (properties `((upstream-name . "stable")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rmutil))
+    (home-page "https://www.commanster.eu/rcode.html")
+    (synopsis
+     "Probability functions and regression models for stable distributions")
+    (description
+     "This package provides density, distribution, quantile and hazard functions
+of a stable variate; generalized regression models for the parameters of a stable
+distribution.")
+    (license license:gpl2+)))
+
 (define-public r-statip
   (package
     (name "r-statip")