diff mbox series

[bug#59870,07/12] gnu: Add r-modeest.

Message ID 20221207051837.10970-7-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#59870,01/12] gnu: Add r-statip. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 7, 2022, 5:18 a.m. UTC
* gnu/packages/cran.scm (r-modeest): New variable.
---
 gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6239a53d85..4e35435e46 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31049,6 +31049,31 @@  (define-public r-modeldata
 model-related packages.")
     (license license:expat)))
 
+(define-public r-modeest
+  (package
+    (name "r-modeest")
+    (version "2.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "modeest" version))
+              (sha256
+               (base32
+                "087dw0013y4m7fcl06mxylh9lnp6acysl80d80r9srv4pw4r950s"))))
+    (properties `((upstream-name . "modeest")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-fbasics
+           r-stable
+           r-stabledist
+           r-statip))
+    (home-page "https://github.com/paulponcet/modeest")
+    (synopsis "Mode estimations for univariate data or distributions")
+    (description
+     "The package provides estimators of the mode of univariate unimodal (and
+sometimes multimodal) data and values of the modes of usual probability
+distributions.")
+    (license license:gpl3)))
+
 (define-public r-conflicted
   (package
     (name "r-conflicted")