diff mbox series

[bug#59113,8/9] gnu: asdf-astropy: Update to 0.2.2

Message ID 20221107230656.28187-8-sharlatanus@gmail.com
State New
Headers show
Series gnu: gwcs: Fix build, update to 0.18.12 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Nov. 7, 2022, 11:06 p.m. UTC
* gnu/packages/astronomy.scm (python-asdf-astropy): Update to 0.2.0.
  [build-system]: Use pyproject-build-system.
  [arguments]: Remove redundant.
---
 gnu/packages/astronomy.scm | 20 +++++++++-----------
 1 file changed, 9 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index cc46006865..ead5c39f46 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2153,22 +2153,20 @@  (define python-asdf-unit-schemas
 (define-public python-asdf-astropy
   (package
     (name "python-asdf-astropy")
-    (version "0.1.2")
+    (version "0.2.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "asdf_astropy" version))
        (sha256
-        (base32 "0bzgah7gskvnz6jcrzipvzixv8k2jzjkskqwxngzwp4nxgjbcvi4"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest")))))))
+        (base32 "1b0v4cl7xvly3x1k5k2rvc2l32jqgqp0iyf1j20fkvj450sx74f2"))))
+    (build-system pyproject-build-system)
+    ;; Starting from v0.2.0 the test suite contains massive set of unit tests.
+    ;; It takes 4+ minutes to pass all of them with a lot of warnings
+    ;; but tests are completed successfully in the end:
+    ;; 
+    ;; 4065 passed, 8146 warnings in 271.78s (0:04:31)
+    ;; 
     (native-inputs
      (list python-coverage
            python-h5py