diff mbox series

[bug#59113,9/9] gnu: gwcs: Fix build, update to 0.18.2

Message ID 20221107230656.28187-9-sharlatanus@gmail.com
State New
Headers show
Series gnu: gwcs: Fix build, update to 0.18.12 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Nov. 7, 2022, 11:06 p.m. UTC
* gnu/packages/astronomy.scm (python-gwcs): Fix build and update to 0.18.2.
  [build-system]: Use pyproject-build-system.
  [arguments]: Remove redundant.
  [native-inputs]: Use python-jsonschema-next over python-jsonschema to
  fix tests failing to run due to python-asdf issue with low version of
  jsonschema, see https://github.com/asdf-format/asdf/pull/1203.
---
 gnu/packages/astronomy.scm | 16 ++++------------
 1 file changed, 4 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ead5c39f46..b820494407 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2226,24 +2226,16 @@  (define python-asdf-wcs-schemas
 (define-public python-gwcs
   (package
     (name "python-gwcs")
-    (version "0.18.0")
+    (version "0.18.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "gwcs" version))
        (sha256
-        (base32 "194j49m8xjjzv9pp8cnj06igz8sdxb0nphyybcc7mhigw0f0kr30"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "python" "-m" "pytest")))))))
+        (base32 "0v9qcq6zl74d6s882s6xmas144jfalvll6va8rvrxmvpx4vqjzhg"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-jsonschema
+     (list python-jsonschema-next
            python-jmespath
            python-pytest
            python-pytest-doctestplus