diff mbox series

[bug#59113,1/9] gnu: Add asdf-standard

Message ID 20221107230656.28187-1-sharlatanus@gmail.com
State New
Headers show
Series gnu: gwcs: Fix build, update to 0.18.12 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Nov. 7, 2022, 11:06 p.m. UTC
* gnu/packages/astronomy.scm (python-asdf-standard): New variable.
---
 gnu/packages/astronomy.scm | 42 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index dd27f4e530..92a807a9a5 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -73,6 +73,7 @@  (define-module (gnu packages astronomy)
   #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix download)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
@@ -1945,6 +1946,47 @@  (define-public python-asdf
 implementation of the ASDF Standard.")
     (license license:bsd-3)))
 
+(define-public python-asdf-standard
+  (package
+    (name "python-asdf-standard")
+    (version "1.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "asdf_standard" version))
+       (sha256
+        (base32
+         "0i7xdjwn5prg2hcnf1zhw57mszc68jjr5sv4rimpzcg7f2dgzn5g"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'remove-blocking-tests
+                          (lambda _
+                            ;; Remove tests require python-asdf where
+                            ;; python-asdf require python-asdf-standard,
+                            ;; break circular dependencies.
+                            (for-each delete-file
+                                      (list "tests/test_manifests.py"
+                                            "tests/test_integration.py")))))))
+    (native-inputs (list python-astropy
+                         python-jsonschema-next
+                         python-pypa-build
+                         python-pytest-7.1
+                         python-packaging
+                         python-setuptools-scm))
+    (propagated-inputs (list python-importlib-resources))
+    (home-page "https://asdf-standard.readthedocs.io/")
+    (synopsis "ASDF standard schemas")
+    (description
+     "This package provides Python implementation of @acronym{ASDF, Advanced
+Scientific Data Format} - a proposed next generation interchange format for
+scientific data.  ASDF aims to exist in the same middle ground that made FITS
+so successful, by being a hybrid text and binary format: containing human
+editable metadata for interchange, and raw binary data that is fast to load
+and use.  Unlike FITS, the metadata is highly structured and is designed
+up-front for extensibility.")
+    (license license:bsd-3)))
+
 (define python-asdf-transform-schemas
   (package
     (name "python-asdf-transform-schemas")