diff mbox series

[bug#58879,1/5] gnu: Add r-deco.

Message ID 20221029231608.13909-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#58879,1/5] gnu: Add r-deco. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu Oct. 29, 2022, 11:16 p.m. UTC
* gnu/packages/bioconductor.scm (r-deco): New variable.
---
 gnu/packages/bioconductor.scm | 42 +++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)


base-commit: ac51b9c86d58cfdb13ee643a2fdc8e979939a260

Comments

Ricardo Wurmus Oct. 31, 2022, 7:06 p.m. UTC | #1
Applied all with minor changes (indentation, license, description).

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b8535250f9..2f2268e5e6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3075,6 +3075,48 @@  (define-public r-decipher
 biological sequences.")
     (license license:gpl3)))
 
+(define-public r-deco
+  (package
+    (name "r-deco")
+    (version "1.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "deco" version))
+              (sha256
+               (base32
+                "18n5zgln33c79jbjzjlivs8ihyg8zci6minfqlvagxgzcpa67k0m"))))
+    (properties `((upstream-name . "deco")))
+    (build-system r-build-system)
+    (propagated-inputs
+      (list r-ade4
+            r-annotationdbi
+            r-biobase
+            r-biocparallel
+            r-biocstyle
+            r-cluster
+            r-foreign
+            r-gdata
+            r-ggplot2
+            r-gplots
+            r-gridextra
+            r-limma
+            r-locfit
+            r-made4
+            r-rcolorbrewer
+            r-reshape2
+            r-scatterplot3d
+            r-sfsmisc
+            r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/fjcamlab/deco")
+    (synopsis "Decomposing heterogeneous cohorts using omic data profiling")
+    (description
+     "The package discovers differential features in hetero- and homogeneous omic
+data by a two-step method including subsampling @code{LIMMA} and @code{NSCA}.
+@code{DECO} reveals feature associations to hidden subclasses not exclusively
+related to higher deregulation levels.")
+    (license (license:fsdg-compatible "GPL (>=3)"))))
+
 (define-public r-deconvr
   (package
     (name "r-deconvr")