diff mbox series

[bug#57462,08/15] gnu: python-path: Don't ask to run tests when cross-compiling.

Message ID 20220828144748.15575-8-maximedevos@telenet.be
State Accepted
Headers show
Series Don't ask to run tests when cross-compiling. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

M Aug. 28, 2022, 2:47 p.m. UTC
* gnu/packages/python-xyz.scm
(python-path)[arguments]{#:tests?}: When cross-compiling, set to #false.
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4019cc0134..7491b7bb41 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12270,7 +12270,7 @@  (define-public python-path
      (substitute-keyword-arguments
          (package-arguments python-path-bootstrap)
        ((#:tests? _ #f)
-        #t)
+        (not (%current-target-system)))
        ((#:phases phases #~%standard-phases)
         #~(modify-phases #$phases
             (replace 'check