diff mbox series

[bug#57462,15/15] gnu: yt-dlp: Don't ask to run tests when cross-compiling.

Message ID 20220828144748.15575-15-maximedevos@telenet.be
State Accepted
Headers show
Series Don't ask to run tests when cross-compiling. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

M Aug. 28, 2022, 2:47 p.m. UTC
* gnu/packages/video.scm
(yt-dlp)[arguments]{#:tests?}: When cross-compiling, set to #false.
---
 gnu/packages/video.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Mathieu Othacehe Aug. 30, 2022, 7:02 a.m. UTC | #1
Hello Maxime,

I pushed the series.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7f451a8925..f744f04322 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2495,7 +2495,7 @@  (define-public yt-dlp
                                           "completions/zsh/_yt-dlp"))))))
     (arguments
      (substitute-keyword-arguments (package-arguments youtube-dl)
-       ((#:tests? _) #t)
+       ((#:tests? _) (not (%current-target-system)))
        ((#:phases phases)
         `(modify-phases ,phases
            ;; See the comment for the corresponding phase in youtube-dl.