diff mbox series

[bug#57462,06/15] gnu: proot: Don't ask to run tests when cross-compiling.

Message ID 20220828144748.15575-6-maximedevos@telenet.be
State Accepted
Headers show
Series Don't ask to run tests when cross-compiling. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

M Aug. 28, 2022, 2:47 p.m. UTC
* gnu/packages/linux.scm
(proot)[arguments]{#:tests?}: When cross-compiling, set to #false.
---
 gnu/packages/linux.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 19ba30aa16..4e472de7c7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7685,9 +7685,9 @@  (define-public proot
      ;; Disable the test suite on armhf-linux, as there are too many
      ;; failures to keep track of (see for example:
      ;; https://github.com/proot-me/proot/issues/286).
-     `(#:tests? ,(not (string-prefix? "armhf"
-                                      (or (%current-target-system)
-                                          (%current-system))))
+     `(#:tests? ,(not (or (%current-target-system)
+                          (string-prefix? "armhf"
+                                          (or (%current-system)))))
        #:make-flags '("-C" "src")
        #:phases (modify-phases %standard-phases
                   (add-after 'unpack 'patch-sources