diff mbox series

[bug#57462,01/15] gnu: ghc-statistics: Properly enable tests.

Message ID 20220828144748.15575-1-maximedevos@telenet.be
State Accepted
Headers show
Series Don't ask to run tests when cross-compiling. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

M Aug. 28, 2022, 2:47 p.m. UTC
The comment states there are test failures and hence it is implied that the
intent was to disable tests, not enable them, but tests pass and the code
below enabled tests instead of disabling them.

Remove #:tests? #true to satisfy the tests-true linter.

* gnu/packages/haskell-xyz.scm
(ghc-statistics)[arguments]{#:tests?}: Remove.
---
 gnu/packages/haskell-xyz.scm | 3 ---
 1 file changed, 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 0ce47e0902..039f4871f2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -12000,9 +12000,6 @@  (define-public ghc-statistics
         (base32
          "0j9awbg47fzb58k5z2wgkp6a0042j7hqrl1g6lyflrbsfswdp5n4"))))
     (build-system haskell-build-system)
-    (arguments
-     '(;; Two tests fail: "Discrete CDF is OK" and "Quantile is CDF inverse".
-       #:tests? #t))
     (inputs
      (list ghc-aeson
            ghc-async