diff mbox series

[bug#55474,v2,07/17] gnu: Add python-django-request.

Message ID 20220809171332.25824-7-ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,v2,01/17] gnu: python-django-taggit: Update to 2.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 9, 2022, 5:13 p.m. UTC
* gnu/packages/django.scm (python-django-request): New variable.
---
 gnu/packages/django.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 617c897ba8..600ea055b8 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -257,6 +257,38 @@  (define-public python-django-localflavor
 that are useful for particular countries or cultures.")
     (license license:bsd-3)))
 
+(define-public python-django-request
+  (package
+    (name "python-django-request")
+    (version "1.5.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "django-request" version))
+       (sha256
+        (base32 "0g5vj7kl5jn03m8h9jd0fpmhhvaywrhw01fcphcah4vf0y40ly00"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs #:allow-other-keys)
+             (if tests?
+                 (invoke "python" "runtests.py")
+                 (format #t "test suite not run~%")))))))
+    (propagated-inputs
+     (list python-dateutil python-django python-six))
+    (native-inputs
+     (list python-sqlparse python-mock))
+    (home-page "https://django-request.readthedocs.io")
+    (synopsis
+     "Statistics module for django")
+    (description
+     "This package provides a statistics module for django.  It stores
+requests in a database for admins to see, it can also be used to get
+statistics on who is online etc.")
+    (license license:expat)))
+
 (define-public python-django-simple-math-captcha
   (package
     (name "python-django-simple-math-captcha")