diff mbox series

[bug#55474,v2,17/17] gnu: Add python-wagtail-localize.

Message ID 20220809171332.25824-17-ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,v2,01/17] gnu: python-django-taggit: Update to 2.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 9, 2022, 5:13 p.m. UTC
* gnu/packages/django.scm (python-wagtail-localize): New variable.
---
 gnu/packages/django.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Nicolas Graves Dec. 23, 2022, 10:21 a.m. UTC | #1
Hi!
Quick reminder for this patch series waiting for 4 months ;)
Lars-Dominik Braun Dec. 29, 2022, 3:33 p.m. UTC | #2
Hi Nicolas,

> Quick reminder for this patch series waiting for 4 months ;)

does it still make sense to add wagtail 2.16? There’s release 4.1.1
available. Maybe we can also drop the extra versions of beautifulsoup4
and psycopg2, since both got updated in the meantime.

Cheers,
Lars
Lars-Dominik Braun Jan. 5, 2023, 7:53 a.m. UTC | #3
Hi Nicolas,

> I'll come up with a new patch series in the coming weeks merging this
> one, 57094, and updating up to the latest version. (I didn't have the
> knowledge or confidence to do it this way 8 months ago).
alright. Please send it as v3 to #55474. Also note that we have
pyproject-build-system now, which makes your life easier for
pyproject.toml-based packages (i.e. no custom phases required).

Thanks,
Lars
Nicolas Graves June 13, 2023, 7:09 a.m. UTC | #4
On 2023-01-05 08:53, Lars-Dominik Braun wrote:

> Hi Nicolas,
>
>> I'll come up with a new patch series in the coming weeks merging this
>> one, 57094, and updating up to the latest version. (I didn't have the
>> knowledge or confidence to do it this way 8 months ago).
> alright. Please send it as v3 to #55474. Also note that we have
> pyproject-build-system now, which makes your life easier for
> pyproject.toml-based packages (i.e. no custom phases required).

Hey Lars,

I've sent an updated patch series. The v4 uses pyproject-build-system. 

>
> Thanks,
> Lars
>
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 934aa8e95a..cd88e1fac3 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1584,3 +1584,33 @@  (define-public python-wagtail
     (description "This package provides a Content Management System based on
 Django.")
     (license license:bsd-3)))
+
+(define-public python-wagtail-localize
+  (package
+    (name "python-wagtail-localize")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/wagtail/wagtail-localize")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "014vcjzm1akbjinzqksqi228ic97f4brl0qvhxlyr42p49nxgh0y"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs #:allow-other-keys)
+             (if tests?
+                 (invoke "python" "testmanage.py")
+                 (format #t "test suite not run~%")))))))
+    (propagated-inputs (list python-django python-polib python-wagtail))
+    (native-inputs (list python-dj-database-url python-freezegun))
+    (home-page "https://www.wagtail-localize.org")
+    (synopsis "Translating for Wagtail Content Management System (CMS)")
+    (description "This package provides a translation plugin for Wagtail CMS.")
+    (license license:bsd-3)))