diff mbox series

[bug#55474,v2,10/17] gnu: Add python-beautifulsoup4-4.8.

Message ID 20220809171332.25824-10-ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,v2,01/17] gnu: python-django-taggit: Update to 2.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Aug. 9, 2022, 5:13 p.m. UTC
* gnu/packages/python-xyz.scm (python-beautifulsoup4-4.8): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c3b1da69ac..bb8552f248 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9390,6 +9390,39 @@  (define-public python-beautifulsoup4
 converts incoming documents to Unicode and outgoing documents to UTF-8.")
     (license license:expat)))
 
+(define-public python-beautifulsoup4-4.8
+  (package
+    (inherit python-beautifulsoup4)
+    (name "python-beautifulsoup4")
+    (version "4.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://www.crummy.com/software/BeautifulSoup/bs4/download/"
+             "4.8/beautifulsoup4-" version ".tar.gz"))
+       (sha256
+        (base32 "0aj6ll0zpmm32g3919xxclwincacdr6dymkscmvhha8wn1g85z85"))))
+    (arguments
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         ;; The Python 2 source is the definitive source of beautifulsoup4. We
+         ;; must use this conversion script when building with Python 3. The
+         ;; conversion script also runs the tests.
+         ;; For more information, see the file 'convert-py3k' in the source
+         ;; distribution.
+         (add-before 'build 'convert-py3k
+           (lambda _
+             (substitute* "convert-py3k"
+               (("\\(cd py3k && python3 -m unittest discover -s bs4\\)") ""))
+             (invoke "./convert-py3k")
+             (delete-file-recursively "bs4")
+             (mkdir-p "bs4")
+             (copy-recursively "py3k/bs4" "bs4")
+             (substitute* "setup.py"
+               (("use_2to3 = True,") "")))))))))
+
 (define-public python-soupsieve
   (package
     (name "python-soupsieve")