diff mbox series

[bug#51314,v4,12/14] gnu: Add octoprint-firmwarecheck.

Message ID 20220529182746.314668-13-monego@posteo.net
State New
Headers show
Series Add Octoprint (web UI for 3d printers). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego May 29, 2022, 6:27 p.m. UTC
* gnu/packages/printers.scm (octoprint-firmwarecheck): New variable.
---
 gnu/packages/printers.scm | 30 +++++++++++++++++++++++++++++-
 1 file changed, 29 insertions(+), 1 deletion(-)

Comments

M May 29, 2022, 9:51 p.m. UTC | #1
Vinicius Monego schreef op zo 29-05-2022 om 18:27 [+0000]:
> +(define-public octoprint-firmwarecheck
> +  (package
> +    (name "octoprint-firmwarecheck")
> +    (version "2021.10.11")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "OctoPrint-FirmwareCheck" version))
> +       (sha256
> +        (base32 "17prs0rmzglw75gkf6j7qypxisjvcfk2mbsyfqrjdbwg99i62s2h"))))

I see a binary at
<https://github.com/OctoPrint/OctoPrint-FirmwareCheck/blob/master/octoprint_firmware_check/translations/de/LC_MESSAGES/messages.mo>
diff mbox series

Patch

diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index 012731b7cd..ca7caad01f 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -27,7 +27,8 @@  (define-module (gnu packages printers)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages qt))
+  #:use-module (gnu packages qt)
+  #:use-module (gnu packages python-web))
 
 ;; This is a module for packages related to printer-like devices, but not
 ;; related to CUPS.
@@ -55,6 +56,33 @@  (define-public octoprint-pisupport
 observed on your Pi or if your Pi is unsupported.")
     (license license:agpl3)))
 
+(define-public octoprint-firmwarecheck
+  (package
+    (name "octoprint-firmwarecheck")
+    (version "2021.10.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "OctoPrint-FirmwareCheck" version))
+       (sha256
+        (base32 "17prs0rmzglw75gkf6j7qypxisjvcfk2mbsyfqrjdbwg99i62s2h"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'sanity-check))))      ; checks for Octoprint
+    (propagated-inputs
+     (list python-flask))
+    (home-page "https://github.com/OctoPrint/OctoPrint-FirmwareCheck")
+    (synopsis "Plugin to check for unsafe or broken printer firmwares")
+    (description "The Firmware Check plugin tries to identify printers
+or rather printer firmware with known safety issues, such as disabled
+thermal runaway protection, or other kinds of severe issues, like known
+communication crippling bugs, and displays a warning box to logged in users
+on identification of such a firmware.")
+    (license license:agpl3)))
+
 (define-public robocut
   (package
     (name "robocut")