diff mbox series

[bug#51314,v4,04/14] gnu: Add python-zipstream-ng.

Message ID 20220529182746.314668-5-monego@posteo.net
State New
Headers show
Series Add Octoprint (web UI for 3d printers). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego May 29, 2022, 6:27 p.m. UTC
* gnu/packages/python-xyz.scm (python-zipstream-ng): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f529bf1216..b7ad14d735 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10949,6 +10949,29 @@  (define-public python-sarge
 command pipeline functionality.")
     (license license:bsd-3)))
 
+(define-public python-zipstream-ng
+  (package
+    (name "python-zipstream-ng")
+    (version "1.3.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "zipstream-ng" version))
+       (sha256
+        (base32 "1xzxizz4icdky2mc2yi971h9whmgsdi0m4riqsc7sncbx6p97zk9"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest python-pytest-cov))
+    (home-page "https://github.com/pR0Ps/zipstream-ng")
+    (synopsis "Streamable zip file generator")
+    (description "This package provides a streamable zip file generator.  It
+can package and stream many files and folders on the fly without needing
+temporary files or excessive memory.  It Includes the ability to calculate the
+total size of the stream before any data is actually added (provided no
+compression is used).  This makes it ideal for use in web applications since
+the total size can be used to set the @code{Content-Length} header without
+having to generate the entire file first.")
+    (license license:lgpl3)))
+
 (define-public python-sentry-sdk
   (package
     (name "python-sentry-sdk")