diff mbox series

[bug#51314,v4,03/14] gnu: Remove python-zipstream-new.

Message ID 20220529182746.314668-4-monego@posteo.net
State New
Headers show
Series Add Octoprint (web UI for 3d printers). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego May 29, 2022, 6:27 p.m. UTC
This package was apparently abandoned by upstream (last commit in 2020) and
replaced by zipstream-ng, which will be added in the next commit.

* gnu/packages/python-xyz.scm (python-zipstream-new): Remove variable.
---
 gnu/packages/python-xyz.scm | 27 ---------------------------
 1 file changed, 27 deletions(-)

Comments

M May 29, 2022, 6:35 p.m. UTC | #1
Vinicius Monego schreef op zo 29-05-2022 om 18:27 [+0000]:
> -    (synopsis "Zipfile generator that takes input files as well as streams")
> -    (description "@code{zipstream.py} is a zip archive generator based on
> -@code{zipfile.py}.  It was created to generate a zip file generator for
> -streaming.  This is beneficial for when you want to provide a downloadable
> -archive of a large collection of regular files, which would be infeasible
> -to generate the archive prior to downloading or of a very large file that
> -you do not want to store entirely on disk or on memory.")

Any particular reason for changing the description and synopsis?

> + It Includes the ability to calculate the
Typo: Includes -> includes

(Only looked at the description & synopsis)
Vinicius Monego May 30, 2022, 8:26 p.m. UTC | #2
Em dom, 2022-05-29 às 20:35 +0200, Maxime Devos escreveu:
> Vinicius Monego schreef op zo 29-05-2022 om 18:27 [+0000]:
> > -    (synopsis "Zipfile generator that takes input files as well as
> > streams")
> > -    (description "@code{zipstream.py} is a zip archive generator
> > based on
> > -@code{zipfile.py}.  It was created to generate a zip file
> > generator for
> > -streaming.  This is beneficial for when you want to provide a
> > downloadable
> > -archive of a large collection of regular files, which would be
> > infeasible
> > -to generate the archive prior to downloading or of a very large
> > file that
> > -you do not want to store entirely on disk or on memory.")
> 
> Any particular reason for changing the description and synopsis?
> 

They were not "changed", these are different packages by different
authors and the synopses and descriptions are adaptations of the
author-provided ones to meet Guix standards.

> > + It Includes the ability to calculate the
> Typo: Includes -> includes
> 
> (Only looked at the description & synopsis)

Thanks, didn't notice that.

Vinicius
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 06502fd8f0..f529bf1216 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10949,33 +10949,6 @@  (define-public python-sarge
 command pipeline functionality.")
     (license license:bsd-3)))
 
-(define-public python-zipstream-new
-  (package
-    (name "python-zipstream-new")
-    (version "1.1.8")
-    (source
-     (origin
-       (method git-fetch)               ; no tests in PyPI release
-       (uri (git-reference
-             (url "https://github.com/arjan-s/python-zipstream")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "14vhgg8mcjqi8cpzrw8qzbij2fr2a63l2a8fhil21k2r8vzv92cv"))))
-    (build-system python-build-system)
-    (native-inputs
-     (list python-nose))
-    (home-page "https://github.com/arjan-s/python-zipstream")
-    (synopsis "Zipfile generator that takes input files as well as streams")
-    (description "@code{zipstream.py} is a zip archive generator based on
-@code{zipfile.py}.  It was created to generate a zip file generator for
-streaming.  This is beneficial for when you want to provide a downloadable
-archive of a large collection of regular files, which would be infeasible
-to generate the archive prior to downloading or of a very large file that
-you do not want to store entirely on disk or on memory.")
-    ;; No copyright headers in the source.  The LICENSE file indicates GPL3.
-    (license license:gpl3)))
-
 (define-public python-sentry-sdk
   (package
     (name "python-sentry-sdk")