diff mbox series

[bug#51314,v4,11/14] gnu: Add octoprint-pisupport.

Message ID 20220529182746.314668-12-monego@posteo.net
State New
Headers show
Series Add Octoprint (web UI for 3d printers). | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego May 29, 2022, 6:27 p.m. UTC
* gnu/packages/printers.scm (octoprint-pisupport): New variable.
---
 gnu/packages/printers.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

M May 29, 2022, 9:47 p.m. UTC | #1
Vinicius Monego schreef op zo 29-05-2022 om 18:27 [+0000]:
> +     `(#:tests? #f                      ; no tests

I see a test at
<https://github.com/OctoPrint/OctoPrint-PiSupport/blob/main/tests/test_pi_support.py>.

> +       (modify-phases %standard-phases
> +         (delete 'sanity-check))))      ; checks for Octoprint

Can probably be removed by adding octoprint as input (for the tests).

Greetings,
Maxime.
Vinicius Monego May 30, 2022, 8:35 p.m. UTC | #2
Em dom, 2022-05-29 às 23:47 +0200, Maxime Devos escreveu:
> Vinicius Monego schreef op zo 29-05-2022 om 18:27 [+0000]:
> > +     `(#:tests? #f                      ; no tests
> 
> I see a test at
> <
> https://github.com/OctoPrint/OctoPrint-PiSupport/blob/main/tests/test_
> pi_support.py>.
> 

It's not available in PyPI. I haven't tried running that test from the
repository either.

> > +       (modify-phases %standard-phases
> > +         (delete 'sanity-check))))      ; checks for Octoprint
> 
> Can probably be removed by adding octoprint as input (for the tests).
> 
> Greetings,
> Maxime.

octoprint-pisupport is a mandatory input for octoprint, it will be
checked for in sanity-check and that would introduce a circular
dependency. I could have a look to see if it's worth introducing
octoprint-minimal to bootstrap the plugins.
diff mbox series

Patch

diff --git a/gnu/packages/printers.scm b/gnu/packages/printers.scm
index f78923966c..012731b7cd 100644
--- a/gnu/packages/printers.scm
+++ b/gnu/packages/printers.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2022 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,8 +20,10 @@ 
 
 (define-module (gnu packages printers)
   #:use-module (guix packages)
+  #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages pkg-config)
@@ -29,6 +32,29 @@  (define-module (gnu packages printers)
 ;; This is a module for packages related to printer-like devices, but not
 ;; related to CUPS.
 
+(define-public octoprint-pisupport
+  (package
+    (name "octoprint-pisupport")
+    (version "2022.3.28")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "OctoPrint-PiSupport" version))
+       (sha256
+        (base32 "11yzcyyia9dyiw428kjwysybxxh93dbc0sl7p59kda84iqwj1m5z"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'sanity-check))))      ; checks for Octoprint
+    (home-page "https://github.com/OctoPrint/OctoPrint-PiSupport")
+    (synopsis "Plugin to provide additional information about your Pi")
+    (description "The Pi Support plugin provides additional information about
+your Pi in the UI and also alerts you about undervoltage or overheating issues
+observed on your Pi or if your Pi is unsupported.")
+    (license license:agpl3)))
+
 (define-public robocut
   (package
     (name "robocut")