diff mbox series

[bug#55474,07/18] gnu: Add python-willow.

Message ID 20220517075448.32638-7-ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,01/18] gnu: python-django-taggit: Update to 2.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves May 17, 2022, 7:54 a.m. UTC
* gnu/packages/python-xyz.scm (python-willow): New variable.
---
 gnu/packages/python-xyz.scm | 53 +++++++++++++++++++++++++++----------
 1 file changed, 39 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f67a93f4b..308ea79075 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7550,25 +7550,50 @@  (define-public python-pillow-simd
     (description "This package is a fork of Pillow which adds support for SIMD
 parallelism.")))
 
-(define-public python-imagecodecs
+(define-public python-willow
   (package
-    (name "python-imagecodecs")
-    (version "2021.3.31")
+    (name "python-willow")
+    (version "1.4.1")
     (source
       (origin
         (method url-fetch)
-        (uri (pypi-uri "imagecodecs" version))
+        (uri (pypi-uri "Willow" version))
         (sha256
-          (base32
-            "0q7pslb6wd56vbcq2mdxwsiha32mxjr7mgqqfbq5w42q601p9pi0"))
-        (modules '((guix build utils)))
-        (snippet
-         '(begin
-            ;; Unbundle 3rd party modules.
-            (delete-file-recursively "3rdparty")
-            ;; Delete pre-generated Cython files.
-            (for-each delete-file (find-files "imagecodecs" "_.*\\.c$"))
-            #t))))
+          (base32 "03ccxy5j3w5gsjz5nbnlya1drhga3gc2xxqbsi40pq1ihm9gzy0d"))))
+    (build-system python-build-system)
+    (inputs
+     (list freetype lcms libjpeg-turbo libtiff libwebp openjpeg zlib))
+    (home-page "https://github.com/wagtail/Willow")
+    (synopsis
+     "A wrapper that combines the functionality of multiple Python image
+libraries into one API")
+    (description
+     "Willow is a simple image library that combines the APIs of Pillow, Wand
+and OpenCV. It converts the image between the libraries when necessary. Willow
+currently has basic resize and crop operations, face and feature detection and
+animated GIF support. New operations and library integrations can also be
+easily implemented.")
+    (license license:bsd-3)))
+
+(define-public python-imagecodecs
+  (package
+    (name "python-imagecodecs")
+    (version "2021.3.31")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "imagecodecs" version))
+       (sha256
+         (base32
+          "0q7pslb6wd56vbcq2mdxwsiha32mxjr7mgqqfbq5w42q601p9pi0"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; Unbundle 3rd party modules.
+           (delete-file-recursively "3rdparty")
+           ;; Delete pre-generated Cython files.
+           (for-each delete-file (find-files "imagecodecs" "_.*\\.c$"))
+           #t))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ; Tests are disabled, because dependencies are missing.