diff mbox series

[bug#55474,01/18] gnu: python-django-taggit: Update to 2.1.0.

Message ID 20220517075448.32638-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,01/18] gnu: python-django-taggit: Update to 2.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves May 17, 2022, 7:54 a.m. UTC
* gnu/packages/django.scm (python-django-taggit): Update to 2.1.0.
---
 gnu/packages/django.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

Comments

Nicolas Graves June 12, 2022, 6:25 p.m. UTC | #1
Quick reminder ;)

This series of patches implement the wagtail python package, and is
functional and tested.

Cheers,

Nicolas Graves

help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 55474@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> -- 
> 55474: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=55474
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
Nicolas Graves Aug. 17, 2023, 4:49 p.m. UTC | #2
On 2022-06-12 20:25, Nicolas Graves via Guix-patches via wrote:

> Quick reminder ;)
>
> This series of patches implement the wagtail python package, and is
> functional and tested.

Maybe if it's a lot of updates at once, and the Guix QA tool is unable
to evaluate them, you can set a new python branch to test these? I have
them ontop of my local Guix, but since it starts to trigger a few (the
total number of concerned packages is still under what would be needed
for another branch I think) but very long rebuilds, I would really like
to get them merged.

Thanks in advance,
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index d62f4376b6..2abdb784c8 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -308,14 +308,13 @@  (define-public python-django-classy-tags
 (define-public python-django-taggit
   (package
     (name "python-django-taggit")
-    (version "1.3.0")
+    (version "2.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "django-taggit" version))
        (sha256
-        (base32
-         "0bbkabbs77z229ps0800gxfhf75yagp4x4j5jzfysbac3zvkp0sa"))))
+        (base32 "0khqd189xlzs9r5ypjchmvp9isw7xql4f9vgv0l4pzlfsm51xx59"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -324,9 +323,9 @@  (define-public python-django-taggit
            (lambda _
              (invoke "python3" "-m" "django" "test" "--settings=tests.settings"))))))
     (propagated-inputs
-     (list python-django python-isort))
+     (list python-django python-isort python-sqlparse))
     (native-inputs
-     (list python-pytest python-mock))
+     (list python-django-rest-framework))
     (home-page
      "https://github.com/jazzband/django-taggit")
     (synopsis