diff mbox series

[bug#55476,03/18] gnu: Add python-django-modelcluster.

Message ID 20220517075448.32638-3-ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,01/18] gnu: python-django-taggit: Update to 2.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves May 17, 2022, 7:54 a.m. UTC
* gnu/packages/django.scm (python-django-modelcluster): New variable.
---
 gnu/packages/django.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index ea8ed040f8..fee4278708 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -780,6 +780,35 @@  (define-public python-django-contrib-comments
 entries, photos, book chapters, or anything else.")
     (license license:bsd-3)))
 
+(define-public python-django-modelcluster
+  (package
+    (name "python-django-modelcluster")
+    (version "5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri "https://github.com/wagtail/django-modelcluster/archive/refs/tags/v5.3.tar.gz")
+       (sha256
+        (base32 "0xlhlnsr8gingbrsgbzhx79z9ds9i9rfii3gp38xnid01xjwlqln"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs #:allow-other-keys)
+             (if tests?
+                 (invoke "python" "runtests.py")
+                 (format #t "test suite not run~%")))))))
+    (propagated-inputs (list python-django python-pytz))
+    (native-inputs (list python-django-taggit))
+    (home-page "https://github.com/wagtail/django-modelcluster")
+    (synopsis
+     "Django extension to allow working with 'clusters' of models as a single unit")
+    (description
+     "This package provides a Django extension to allow working with
+'clusters' of models as a single unit, independently of the database")
+    (license license:bsd-3)))
+
 (define-public python-django-pipeline
   (package
     (name "python-django-pipeline")