diff mbox series

[bug#55474,16/18] gnu: Add python-telepath.

Message ID 20220517075448.32638-16-ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,01/18] gnu: python-django-taggit: Update to 2.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves May 17, 2022, 7:54 a.m. UTC
* gnu/packages/django.scm (python-telepath): New variable.
---
 gnu/packages/django.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 63aa0a2db7..46891fd044 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1456,3 +1456,32 @@  (define-public python-django-svg-image-form-field
 models that use Django's standard @code{ImageField}, in addition to the
 image files already supported by it.")
     (license license:expat)))
+
+(define-public python-telepath
+  (package
+    (name "python-telepath")
+    (version "0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "telepath" version))
+        (sha256
+          (base32 "0k7q5dqgvcwnslb82ah0g6p772jzjmb6fd4wcdc8r46ibsjg4k7g"))))
+    (build-system python-build-system)
+    (native-inputs (list python-django python-pytest-django))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs #:allow-other-keys)
+             (if tests?
+                 (lambda _
+                   (setenv "DJANGO_SETTINGS_MODULE" "telepath.test_settings")
+                   (invoke "django-admin" "test" "--pythonpath=."))
+                 (format #t "test suite not run~%")))))))
+    (home-page "https://github.com/wagtail/telepath")
+    (synopsis "A library for exchanging data between Python and JavaScript")
+    (description
+      "This package provides a library for exchanging data between Python and
+JavaScript.")
+    (license license:bsd-3)))