diff mbox series

[bug#55240,4/4] gnu: Add r-airpart.

Message ID 20220503065311.9192-4-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#55239,1/4] gnu: Add r-forestplot. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu May 3, 2022, 6:53 a.m. UTC
* gnu/packages/bioconductor.scm (r-airpart): New variable.
---
 gnu/packages/bioconductor.scm | 46 +++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a78903becc..2967c5016b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1877,6 +1877,52 @@  (define-public r-agilp
     ;; GPLv3.
     (license license:gpl3)))
 
+(define-public r-airpart
+  (package
+    (name "r-airpart")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "airpart" version))
+              (sha256
+               (base32
+                "0ljankgvgf8rby4z340wxx8v7acs9yz955p3a40jl6y8rz1svc06"))))
+    (properties `((upstream-name . "airpart")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-apeglm
+           r-clue
+           r-complexheatmap
+           r-dplyr
+           r-dynamictreecut
+           r-emdbook
+           r-forestplot
+           r-ggplot2
+           r-lpsolve
+           r-matrixstats
+           r-mclust
+           r-pbapply
+           r-plyr
+           r-rcolorbrewer
+           r-rlang
+           r-s4vectors
+           r-scater
+           r-singlecellexperiment
+           r-smurf
+           r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/airpart")
+    (synopsis "Differential cell-type-specific allelic imbalance")
+    (description
+     "The @code{airpart} package identifies sets of genes displaying differential
+cell-type-specific allelic imbalance across cell types or states, utilizing
+single-cell allelic counts.  It makes use of a generalized fused lasso with
+binomial observations of allelic counts to partition cell types by their allelic
+imbalance.  Alternatively, a nonparametric method for partitioning cell types
+is offered.  The package includes a number of visualizations and quality control
+functions for examining single cell allelic imbalance datasets.")
+    (license license:gpl2)))
+
 (define-public r-aneufinder
   (package
     (name "r-aneufinder")