diff mbox series

[bug#55239,1/4] gnu: Add r-forestplot.

Message ID 20220503065311.9192-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#55239,1/4] gnu: Add r-forestplot. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu May 3, 2022, 6:53 a.m. UTC
* gnu/packages/cran.scm (r-forestplot): New variable.
X-Debbugs-Cc: rekado@elephly.net
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 098f2eea331121905e3c867f478b22cea3510841

Comments

Ricardo Wurmus Oct. 31, 2022, 7:10 p.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 91c54bac9a..864540adf1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24377,6 +24377,33 @@  (define-public r-forecast
 space models and automatic ARIMA modelling.")
     (license license:gpl3)))
 
+(define-public r-forestplot
+  (package
+    (name "r-forestplot")
+    (version "2.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "forestplot" version))
+              (sha256
+               (base32
+                "0bzwi6ws0qjq1pqiadssynbkxxd4zjp974jfdplmv16fcyszqhyi"))))
+    (properties `((upstream-name . "forestplot")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-checkmate
+           r-magrittr))
+    (native-inputs (list r-knitr))
+    (home-page "https://gforge.se/packages/")
+    (synopsis "Advanced forest plot using @code{grid} graphics")
+    (description
+     "This package provides a forest plot that allows for multiple confidence
+intervals per row, custom fonts for each text element, custom confidence
+intervals, text mixed with expressions, and more.  The aim is to extend the use
+of forest plots beyond meta-analyses.  This is a more general version of the
+original @code{rmeta} package's @code{forestplot()} function and relies heavily
+on the @code{grid} package.")
+    (license license:gpl2)))
+
 (define-public r-formattable
   (package
     (name "r-formattable")