diff mbox series

[bug#53995,29/31] gnu: add rust-valuable-derive-0.1.

Message ID 20220216012305.24710-10-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#53995,01/31] gnu: update rust-anyhow to 1.0.53. | expand

Commit Message

Nicolas Graves Feb. 16, 2022, 1:23 a.m. UTC
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

M Feb. 16, 2022, 11:17 a.m. UTC | #1
Nicolas Graves schreef op wo 16-02-2022 om 02:23 [+0100]:
> +    (synopsis "Macros for the `valuable` crate.")
> +    (description "This package provides macros for the `valuable` crate. This

`foo` is Markdown, not TeXinfo markup.  Perhaps use @code{...} or
@samp{...} instead (not sure which exactly).

Greetings,
Maxime.
M Feb. 16, 2022, 11:18 a.m. UTC | #2
Nicolas Graves schreef op wo 16-02-2022 om 02:23 [+0100]:
> +     `(#:skip-build?
> +       #t

Is this necessary? From (guix)Rust Crates:

   Care should be taken to ensure the correct version of dependencies
are used; to this end we try to refrain from skipping the tests or
using ‘#:skip-build?’ when possible.

with caveat:

  Of course this is not always possible, as the package may be
developed for a different Operating System, depend on features from the
Nightly Rust compiler, or the test suite may have atrophied since it
was released.


Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7c9eea2ec6..a28851e1d8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -67421,6 +67421,32 @@  (define-public rust-v-frame-0.2
 a part of rav1e.")
     (license license:bsd-2)))
 
+(define-public rust-valuable-derive-0.1
+  (package
+    (name "rust-valuable-derive")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "valuable-derive" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0cjvqljzsj891cjzlwv0ihrv4m0n5211a6pr6b7cz42ich66ji4x"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build?
+       #t
+       #:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-1))))
+    (home-page "https://github.com/tokio-rs/valuable")
+    (synopsis "Macros for the `valuable` crate.")
+    (description "This package provides macros for the `valuable` crate. This
+crate provides object-safe value inspection. Use cases include passing
+structured data to trait objects and object-safe serialization.")
+    (license license:expat)))
+
 (define-public rust-value-bag-1
   (package
     (name "rust-value-bag")