diff mbox series

[bug#53995,19/31] gnu: update rust-structopt-0.3 to 0.3.26.

Message ID 20220216012149.24258-10-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#53995,01/31] gnu: update rust-anyhow to 1.0.53. | expand

Commit Message

Nicolas Graves Feb. 16, 2022, 1:21 a.m. UTC
---
 gnu/packages/crates-io.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 75c6335b07..29218e2cd6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -58101,7 +58101,7 @@  (define-public rust-strsim-0.5
 (define-public rust-structopt-0.3
   (package
     (name "rust-structopt")
-    (version "0.3.21")
+    (version "0.3.26")
     (source
      (origin
        (method url-fetch)
@@ -58109,15 +58109,15 @@  (define-public rust-structopt-0.3
        (file-name
         (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "136j0lvjmpv5syi751vxg8vb30gfyv4k81x8d18kxrj6xvbsqxsj"))))
+          (base32 "043sg3qxllann6q9i71d05qp3q13scmcvhxhd950ka2v8ij5qsqc"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-structopt-derive" ,rust-structopt-derive-0.4)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-clap" ,rust-clap-2))))
+      `(#:skip-build? #t
+        #:cargo-inputs
+        (("rust-clap" ,rust-clap-2)
+         ("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-paw" ,rust-paw-1)
+         ("rust-structopt-derive" ,rust-structopt-derive-0.4))))
     (home-page "https://github.com/TeXitoi/structopt")
     (synopsis "Parse command line argument by defining a struct")
     (description