diff mbox series

[bug#53995,14/31] gnu: update rust-serde-json to 1.0.79

Message ID 20220216012149.24258-5-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#53995,01/31] gnu: update rust-anyhow to 1.0.53. | expand

Commit Message

Nicolas Graves Feb. 16, 2022, 1:21 a.m. UTC
---
 gnu/packages/crates-io.scm | 22 ++++++++--------------
 1 file changed, 8 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c16eb20ec7..f6e9b344ef 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -53515,28 +53515,22 @@  (define-public rust-serde-ignored-0.1
 (define-public rust-serde-json-1
   (package
     (name "rust-serde-json")
-    (version "1.0.74")
+    (version "1.0.79")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "serde-json" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0hiixjnrnrvvpyh58av73ds924zgzi4wl0mv8p9nan0w0v6vjazf"))))
+          (base32 "158xd1swdvw6y59bx4avb8vdpj727n54r77xw5f7c15kqfjrz3cf"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
-       (("rust-indexmap" ,rust-indexmap-1)
-        ("rust-itoa" ,rust-itoa-1)
-        ("rust-ryu" ,rust-ryu-1)
-        ("rust-serde" ,rust-serde-1))
-       #:cargo-development-inputs
-       (("rust-automod" ,rust-automod-1)
-        ("rust-rustversion" ,rust-rustversion-1)
-        ("rust-serde-bytes" ,rust-serde-bytes-0.11)
-        ("rust-serde-derive" ,rust-serde-derive-1)
-        ("rust-serde-stacker" ,rust-serde-stacker-0.1)
-        ("rust-trybuild" ,rust-trybuild-1))))
+      `(#:skip-build? #t
+        #:cargo-inputs
+        (("rust-indexmap" ,rust-indexmap-1)
+         ("rust-itoa" ,rust-itoa-1)
+         ("rust-ryu" ,rust-ryu-1)
+         ("rust-serde" ,rust-serde-1))))
     (home-page "https://github.com/serde-rs/json")
     (synopsis "JSON serialization file format")
     (description