diff mbox series

[bug#53995,01/31] gnu: update rust-anyhow to 1.0.53.

Message ID 20220216010836.18743-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#53995,01/31] gnu: update rust-anyhow to 1.0.53. | expand

Commit Message

Nicolas Graves Feb. 16, 2022, 1:08 a.m. UTC
---
 gnu/packages/crates-io.scm | 13 +++++--------
 1 file changed, 5 insertions(+), 8 deletions(-)

Comments

M Feb. 16, 2022, 7:56 a.m. UTC | #1
Nicolas Graves schreef op wo 16-02-2022 om 02:08 [+0100]:
> -     `(#:cargo-development-inputs
> -       (("rust-futures" ,rust-futures-0.3)
> -        ("rust-rustversion" ,rust-rustversion-1)
> -        ("rust-thiserror" ,rust-thiserror-1)
> -        ("rust-trybuild" ,rust-trybuild-1))))

Looking at 'cargo.toml', anyhow still has these ‘development inputs’.
What's the reason for removing them?

> +      `(#:skip-build? #t

This prevents doing "guix build rust-anyhow" to test if 'rust-anyhow'
still builds.  What's the reason for this change?

Greetings,
Maxime.
Nicolas Graves Feb. 16, 2022, 8:08 a.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> [[PGP Signed Part:Undecided]]
> Nicolas Graves schreef op wo 16-02-2022 om 02:08 [+0100]:
>> -     `(#:cargo-development-inputs
>> -       (("rust-futures" ,rust-futures-0.3)
>> -        ("rust-rustversion" ,rust-rustversion-1)
>> -        ("rust-thiserror" ,rust-thiserror-1)
>> -        ("rust-trybuild" ,rust-trybuild-1))))
>
> Looking at 'cargo.toml', anyhow still has these ‘development inputs’.
> What's the reason for removing them?
>
>> +      `(#:skip-build? #t
>
> This prevents doing "guix build rust-anyhow" to test if 'rust-anyhow'
> still builds.  What's the reason for this change?

When I import from guix import crate and get a skip-build, each time I
tried removing it caused the build to fail, because of nightly
features. I assumed it was the case in general, haven't tried it there.

No reason for removing cargo-develpment-inputs, I may have assumed that
skipping the build removed the need for them, but it seems not to be the
case.
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]
M Feb. 16, 2022, 11:08 a.m. UTC | #3
Nicolas Graves schreef op wo 16-02-2022 om 09:08 [+0100]:
> When I import from guix import crate and get a skip-build, each time I
> tried removing it caused the build to fail, because of nightly
> features. I assumed it was the case in general, haven't tried it there.

In this case, this does not seem to be the case, the following builds
(guix build -f):

(use-modules (guix packages) (gnu packages crates-io)
  (guix build-system cargo) (guix download))

;; otherwise 'rust-anyhow@1.0.54' fails to build because the version
;; of 'rust-rustversion' currently in Guix is too old.
(set! rust-rustversion-1
  (package
    (inherit rust-rustversion-1)
    (version "1.0.6")
    (source
      (origin
        (method url-fetch)
        (uri (crate-uri "rustversion" version))
        (file-name (string-append "rust-rustversion" "-" version
".tar.gz"))
        (sha256
          (base32
"0gxj6skypbk0wlbks3pdqb0lclpwbzmyv9xbqkijsvk6zbl3ik7j"))))))

(package
  (inherit rust-anyhow-1)
  (version "1.0.53")
  (source
    (origin
      (inherit (package-source rust-anyhow-1))
      (uri (crate-uri "anyhow" version))
      (file-name
       (string-append "rust-anyhow" "-" version ".tar.gz"))
      (sha256
        (base32
"1q06xg4jn4lpad7lj1af28x5xdwymgl1k820zj2nnrhlbi2mp94l")))))
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d21fb240a8..0dfdf4569a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2763,7 +2763,7 @@  (define-public rust-antidote-1
 (define-public rust-anyhow-1
   (package
     (name "rust-anyhow")
-    (version "1.0.46")
+    (version "1.0.53")
     (source
      (origin
        (method url-fetch)
@@ -2771,15 +2771,12 @@  (define-public rust-anyhow-1
        (file-name
         (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "0w0zm1bqk5kbk834r4xszlzqiln4vw5k1lnlswyjkh24khi2ia1s"))))
+          (base32 "1q06xg4jn4lpad7lj1af28x5xdwymgl1k820zj2nnrhlbi2mp94l"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-development-inputs
-       (("rust-futures" ,rust-futures-0.3)
-        ("rust-rustversion" ,rust-rustversion-1)
-        ("rust-thiserror" ,rust-thiserror-1)
-        ("rust-trybuild" ,rust-trybuild-1))))
+      `(#:skip-build? #t
+        #:cargo-inputs
+        (("rust-backtrace" ,rust-backtrace-0.3))))
     (home-page "https://github.com/dtolnay/anyhow")
     (synopsis "Flexible concrete Error type")
     (description "This package provides a flexible concrete Error type built on