diff mbox series

[bug#53434,08/11] gnu: mesa: Disable tests on i686.

Message ID 20220122025926.22804-8-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#53434,01/11] gnu: gtk-vnc: Remove dependency on GJS on non-x86_64. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Denis 'GNUtoo' Carikli Jan. 22, 2022, 2:59 a.m. UTC
* gnu/packages/gl.scm (mesa)[arguments]<#:tests?>:
Conditionally disable tests.
---
 gnu/packages/gl.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Denis 'GNUtoo' Carikli Jan. 26, 2022, 3:27 a.m. UTC | #1
On Sat, 22 Jan 2022 03:59:23 +0100
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:

> * gnu/packages/gl.scm (mesa)[arguments]<#:tests?>:
> Conditionally disable tests.
Without that patch mesa now seems to build fine.

When trying to build it I have:
$ ./pre-inst-env guix build --check --no-substitutes --rounds=2 mesa
The following graft will be made:
   /gnu/store/gaf97xclvim3x4iak44hrwrj1hr2sczv-mesa-21.3.2.drv
applying 3 grafts for /gnu/store/gaf97xclvim3x4iak44hrwrj1hr2sczv-mesa-21.3.2.drv ...
grafting '/gnu/store/0kg54299yqzv9p1yfhph871qqpin1rkp-mesa-21.3.2-bin' -> '/gnu/store/hvhc1k2aks02zhjzw6s76m7lq3s8qnz5-mesa-21.3.2-bin'...
grafting '/gnu/store/q8fsnspfd3ajwrrjhnsznjp2wmm4f6bc-mesa-21.3.2' -> '/gnu/store/i8jghxbpzp2vf3rk0wd4pks0pc9qbjd3-mesa-21.3.2'...
successfully built /gnu/store/gaf97xclvim3x4iak44hrwrj1hr2sczv-mesa-21.3.2.drv
successfully built /gnu/store/gaf97xclvim3x4iak44hrwrj1hr2sczv-mesa-21.3.2.drv
applying 3 grafts for /gnu/store/gaf97xclvim3x4iak44hrwrj1hr2sczv-mesa-21.3.2.drv ...
grafting '/gnu/store/0kg54299yqzv9p1yfhph871qqpin1rkp-mesa-21.3.2-bin' -> '/gnu/store/hvhc1k2aks02zhjzw6s76m7lq3s8qnz5-mesa-21.3.2-bin'...
grafting '/gnu/store/q8fsnspfd3ajwrrjhnsznjp2wmm4f6bc-mesa-21.3.2' -> '/gnu/store/i8jghxbpzp2vf3rk0wd4pks0pc9qbjd3-mesa-21.3.2'...
successfully built /gnu/store/gaf97xclvim3x4iak44hrwrj1hr2sczv-mesa-21.3.2.drv
successfully built /gnu/store/gaf97xclvim3x4iak44hrwrj1hr2sczv-mesa-21.3.2.drv
successfully built /gnu/store/gaf97xclvim3x4iak44hrwrj1hr2sczv-mesa-21.3.2.drv
/gnu/store/hvhc1k2aks02zhjzw6s76m7lq3s8qnz5-mesa-21.3.2-bin
/gnu/store/i8jghxbpzp2vf3rk0wd4pks0pc9qbjd3-mesa-21.3.2

But using --no-grafts make it really builds:
$ ./pre-inst-env guix build --check --no-substitutes --rounds=2 --no-grafts mesa
The following derivation will be built:
   /gnu/store/f9inawjwgjrb56d3i823ph558iqvc9z9-mesa-21.3.2.drv
building /gnu/store/f9inawjwgjrb56d3i823ph558iqvc9z9-mesa-21.3.2.drv...
starting phase `set-SOURCE-DATE-EPOCH'
phase `set-SOURCE-DATE-EPOCH' succeeded after 0.0 seconds
[...]

And the first build succeeded (I aborted after that as it takes a long
time to build).

Denis.
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index fa49679870..fd21e8b7f6 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
 ;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -348,6 +349,7 @@  (define-public mesa
                   (srfi srfi-1)
                   (guix build utils)
                   (guix build meson-build-system))
+       #:tests? ,(not (target-x86-32?))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'disable-failing-test