diff mbox series

[bug#53434,01/11] gnu: gtk-vnc: Remove dependency on GJS on non-x86_64.

Message ID 20220122025926.22804-1-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#53434,01/11] gnu: gtk-vnc: Remove dependency on GJS on non-x86_64. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Denis 'GNUtoo' Carikli Jan. 22, 2022, 2:59 a.m. UTC
* gnu/packages/gnome.scm (gtk-vnc)[native-inputs]: Provide GJS
only when 'target-x86-64?'.
---
 gnu/packages/gnome.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)


base-commit: cadcbbaf655953b28df9466c07b4b5c63d29b00b
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 088c368054..1ed3acf8ae 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -67,6 +67,7 @@ 
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
 ;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8828,7 +8829,11 @@  (define-public gtk-vnc
     (arguments
      `(#:glib-or-gtk? #t))   ; To wrap binaries and/or compile schemas
     (native-inputs
-     `(("gjs" ,gjs)
+     `(;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
+       ;; dependency on other platforms (FIXME).
+       ,@(if (target-x86-64?)
+             `(("gjs" ,gjs))
+             '())
        ("glib:bin" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("intltool" ,intltool)