diff mbox series

[bug#53434,09/11] gnu: imath: Disable tests on i686.

Message ID 20220122025926.22804-9-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#53434,01/11] gnu: gtk-vnc: Remove dependency on GJS on non-x86_64. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Denis 'GNUtoo' Carikli Jan. 22, 2022, 2:59 a.m. UTC
* gnu/packages/graphjics.scm (imath)[arguments]<#:tests?>:
Conditionally disable tests.
---
 gnu/packages/graphics.scm | 3 +++
 1 file changed, 3 insertions(+)

Comments

Denis 'GNUtoo' Carikli Jan. 26, 2022, 1:06 a.m. UTC | #1
On Sat, 22 Jan 2022 03:59:24 +0100
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:

> * gnu/packages/graphjics.scm (imath)[arguments]<#:tests?>:
> Conditionally disable tests.
This one still fails without this patch. I've attached the build log
for now.

Denis.
Leo Famulari Jan. 26, 2022, 3:17 a.m. UTC | #2
On Wed, Jan 26, 2022 at 02:06:34AM +0100, Denis 'GNUtoo' Carikli wrote:
> On Sat, 22 Jan 2022 03:59:24 +0100
> Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:
> 
> > * gnu/packages/graphjics.scm (imath)[arguments]<#:tests?>:
> > Conditionally disable tests.
> This one still fails without this patch. I've attached the build log
> for now.

We should find out if imath is supposed to work on 32-bit hardware.

Considering its use case, I wouldn't be surprised if it's 64-bit only.
Leo Famulari Jan. 26, 2022, 3:44 a.m. UTC | #3
On Wed, Jan 26, 2022 at 02:06:34AM +0100, Denis 'GNUtoo' Carikli wrote:
> > * gnu/packages/graphjics.scm (imath)[arguments]<#:tests?>:
> > Conditionally disable tests.
> This one still fails without this patch. I've attached the build log
> for now.

The salient parts of the log

------
    dir ~ (0 0 -1), result = 0
  transform box by matrix
ImathTest: /tmp/guix-build-imath-3.1.3.drv-0/source/src/ImathTest/testBoxAlgo.cpp:816: void {anonymous}::boxMatrixTransform(): Assertion `b21 == b2' failed.

      Start 31: Imath.testBox
------

... and ...

------
    extendBy() point for type V2i64
    extendBy() point for type V2f 
ImathTest: /tmp/guix-build-imath-3.1.3.drv-0/source/src/ImathTest/testBox.cpp:257: void {anonymous}::testExtendByPoint(const char*) [with T = Imath_3_1::Vec2<float>]: Assertion `b.min == min && b.max == max' failed. 

      Start 32: Imath.testProcrustes
32/36 Test #32: Imath.testProcrustes ....................   Passed    0.01 sec 
      Start 33: Imath.testTinySVD
------

Upstream report:

https://github.com/AcademySoftwareFoundation/Imath/issues/226
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index b69ab52aec..6bf42d69d1 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -27,6 +27,7 @@ 
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -690,6 +691,8 @@  (define-public imath
        (sha256
         (base32 "1nyld18mf220ghm1vidnfnn0rdns9z5i4l9s66xgd0kfdgarb31f"))))
     (build-system cmake-build-system)
+    (arguments
+     `(#:tests? ,(not (target-x86-32?))))
     (home-page "https://github.com/AcademySoftwareFoundation/Imath")
     (synopsis "Library of math operations for computer graphics")
     (description