diff mbox series

[bug#53434,06/11] gnu: node: Disable tests on i686.

Message ID 20220122025926.22804-6-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#53434,01/11] gnu: gtk-vnc: Remove dependency on GJS on non-x86_64. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Denis 'GNUtoo' Carikli Jan. 22, 2022, 2:59 a.m. UTC
* gnu/packages/node.scm (node)[arguments]<#:tests?>:
Conditionally disable tests.
---
 gnu/packages/node.scm | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index ce94557a8c..1cccfe9263 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021, 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -101,6 +102,7 @@  (define-public node
                            "--shared-zlib"
                            "--without-snapshot"
                            "--with-intl=system-icu")
+       #:tests? ,(not (target-x86-32?))
        ;; Run only the CI tests.  The default test target requires additional
        ;; add-ons from NPM that are not distributed with the source.
        #:test-target "test-ci-js"