diff mbox series

[bug#48842,v2,4/7] gnu: Add python-linkify-it-py.

Message ID 20210607112051.214681-4-monego@posteo.net
State New
Headers show
Series [bug#48842,v2,1/7] gnu: Add python-pytest-datadir. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego June 7, 2021, 11:20 a.m. UTC
* gnu/packages/python-xyz.scm (python-linkify-it-py): New variable.
---
Changed description.

 gnu/packages/python-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0292fdcdfb..d910d370e9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7096,6 +7096,44 @@  cluster without needing to write any wrapper code yourself.")
 content is only for the @code{linkify-it-py} project needs.")
     (license license:expat)))
 
+(define-public python-linkify-it-py
+  (package
+    (name "python-linkify-it-py")
+    (version (package-version python-uc-micro-py))
+    (source
+     (origin
+       ;; There are no tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tsutsu3/linkify-it-py")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00r4sxgvlxkm5k2jwvrsxgzcccfkfzd0knypbcig5almisg7bpl1"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest")))))))
+    (propagated-inputs
+     `(("python-uc-micro-py" ,python-uc-micro-py)))
+    (native-inputs
+     `(("python-black" ,python-black)
+       ("python-coverage" ,python-coverage)
+       ("python-flake8" ,python-flake8)
+       ("python-isort" ,python-isort)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)))
+    (home-page "https://github.com/tsutsu3/linkify-it-py")
+    (synopsis "Links recognition library with full unicode support")
+    (description "This is a Python port of @code{linkify-it}, a JavaScript
+links recognition library with full unicode support.")
+    (license license:expat)))
+
 (define-public python-honcho
   (package
     (name "python-honcho")