diff mbox series

[bug#48842,v2,6/7] gnu: Add python-mdit-py-plugins.

Message ID 20210607112051.214681-6-monego@posteo.net
State New
Headers show
Series [bug#48842,v2,1/7] gnu: Add python-pytest-datadir. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego June 7, 2021, 11:20 a.m. UTC
* gnu/packages/python-xyz.scm (python-mdit-py-plugins): New variable.
---
Changed synopsis and description.

 gnu/packages/python-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 170eb15759..b01a7f5bb8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7184,6 +7184,43 @@  parser in JavaScript), and some of its associated plugins.  Features:
 @end itemize")
     (license license:expat)))
 
+(define-public python-mdit-py-plugins
+  (package
+    (name "python-mdit-py-plugins")
+    (version "0.2.8")
+    (source
+     (origin
+       ;; There are no tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/executablebooks/mdit-py-plugins")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0pq7cgzwb1gcbsdpdp51r3l6mnjdxc4hbfmwk6dy30pfa1lj6x1i"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest")))))))
+    (propagated-inputs
+     `(("python-markdown-it-py" ,python-markdown-it-py)))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-regressions"
+        ,python-pytest-regressions)))
+    (home-page "https://github.com/executablebooks/mdit-py-plugins")
+    (synopsis "Collection of plugins for @code{python-markdown-it-py}")
+    (description "This package provides a collection of plugins for
+@code{python-markdown-it-py}.")
+    (license license:expat)))
+
 (define-public python-honcho
   (package
     (name "python-honcho")