diff mbox series

[bug#48842,v2,5/7] gnu: Add python-markdown-it-py.

Message ID 20210607112051.214681-5-monego@posteo.net
State New
Headers show
Series [bug#48842,v2,1/7] gnu: Add python-pytest-datadir. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego June 7, 2021, 11:20 a.m. UTC
* gnu/packages/python-xyz.scm (python-markdown-it-py): New variable.
---
Changed synopsis and description.

 gnu/packages/python-xyz.scm | 50 +++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d910d370e9..170eb15759 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7134,6 +7134,56 @@  content is only for the @code{linkify-it-py} project needs.")
 links recognition library with full unicode support.")
     (license license:expat)))
 
+(define-public python-markdown-it-py
+  (package
+    (name "python-markdown-it-py")
+    (version "1.1.0")
+    (source
+     (origin
+       ;; There are no tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/executablebooks/markdown-it-py")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0h7rn3rcqfwmnqs97qczwkw9w5g4df8bgn6sw7k149svfqgrkf56"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest")))))))
+    (propagated-inputs
+     `(("python-attrs" ,python-attrs)
+       ("python-typing-extensions"
+        ,python-typing-extensions)))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-linkify-it-py" ,python-linkify-it-py)
+       ("python-psutil" ,python-psutil)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-benchmark"
+        ,python-pytest-benchmark)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-regressions"
+        ,python-pytest-regressions)))
+    (home-page "https://github.com/executablebooks/markdown-it-py")
+    (synopsis "Markdown parser with CommonMark support")
+    (description "This is a Python port of @code{markdown-it} (a Markdown
+parser in JavaScript), and some of its associated plugins.  Features:
+
+@itemize
+@item Follows the CommonMark spec for baseline parsing.
+@item Configurable syntax: Add new rules and even replace existing ones.
+@item Pluggable: Adds syntax extensions to extend the parser.
+@item Safe by default.
+@end itemize")
+    (license license:expat)))
+
 (define-public python-honcho
   (package
     (name "python-honcho")