diff mbox series

[bug#48842,v2,3/7] gnu: Add python-uc-micro-py.

Message ID 20210607112051.214681-3-monego@posteo.net
State New
Headers show
Series [bug#48842,v2,1/7] gnu: Add python-pytest-datadir. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego June 7, 2021, 11:20 a.m. UTC
* gnu/packages/python-xyz.scm (python-uc-micro-py): New variable.
---
Split this patch into two. Added a comment on the top of the definition. Changed synopsis and description.

 gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b63c2852d5..0292fdcdfb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7061,6 +7061,41 @@  cluster without needing to write any wrapper code yourself.")
 (define-public python2-gridmap
   (package-with-python2 python-gridmap))
 
+;; This package's only purpose is to support python-linkify-it-py.  Both
+;; have to be updated at the same time by updating this one.
+(define python-uc-micro-py
+  (package
+    (name "python-uc-micro-py")
+    (version "1.0.1")
+    (source
+     (origin
+       ;; There are no tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tsutsu3/uc.micro-py")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17f55gi55rg47nm88fn3f8851ph03dgykdp011lxr3j6hk18lyfv"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest")))))))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)))
+    (home-page "https://github.com/tsutsu3/uc.micro-py")
+    (synopsis "Data files for @code{python-linkify-it-py}")
+    (description "This is a Python port of @code{uc.micro}.  This package's
+content is only for the @code{python-linkify-it-py} project needs.")
+    (license license:expat)))
+
 (define-public python-honcho
   (package
     (name "python-honcho")