diff mbox series

[bug#47976,06/10] gnu: Add python-serverfiles.

Message ID 20210423172816.73579-6-monego@posteo.net
State Accepted
Headers show
Series Add Orange | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego April 23, 2021, 5:28 p.m. UTC
* gnu/packages/orange.scm (python-serverfiles): New variable.
---
 gnu/packages/orange.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/orange.scm b/gnu/packages/orange.scm
index 1788163721..5713516e58 100644
--- a/gnu/packages/orange.scm
+++ b/gnu/packages/orange.scm
@@ -100,3 +100,24 @@  data-mining application.")
      "Orange Widget Base provides a base widget component for a interactive
 GUI based workflow.  It is primarily used in the Orange framework.")
     (license license:gpl3+)))
+
+(define-public python-serverfiles
+  (package
+    (name "python-serverfiles")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "serverfiles" version))
+       (sha256
+        (base32 "1qgbzgnaxj4wsp2rdas53qxsh0j7xpibq25w6lviwyaqwwrgq42y"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-requests" ,python-requests)))
+    (home-page "https://github.com/biolab/serverfiles")
+    (synopsis "Utility to access files on a HTTP server and store them locally")
+    (description
+     "This package provides an utility that accesses files on a HTTP server
+and stores them locally for reuse.  It is primarily used by the Orange
+framework.")
+    (license license:gpl3+)))