[bug#47976,00/10] Add Orange

Message ID 20210423172547.73266-1-monego@posteo.net
Headers show
Series Add Orange | expand

Message

Vinicius Monego April 23, 2021, 5:25 p.m. UTC
This patchset adds the Orange data mining / data visualization / machine learning toolkit.

I had to disable tests for the orange widget base because unittest failed to load a file. But all tests for orange itself are passing.

Vinicius Monego (10):
  gnu: Add python-anyqt.
  gnu: Add python-pyqtgraph.
  gnu: Add python-qasync.
  gnu: Add python-orange-canvas-core.
  gnu: Add python-orange-widget-base.
  gnu: Add python-serverfiles.
  gnu: Add python-python-louvain.
  gnu: python-pynndescent: Update to 0.5.2.
  gnu: python-opentsne: Update to 0.5.2.
  gnu: Add orange.

 gnu/local.mk                      |   1 +
 gnu/packages/graph.scm            |  22 ++++
 gnu/packages/machine-learning.scm |   8 +-
 gnu/packages/orange.scm           | 211 ++++++++++++++++++++++++++++++
 gnu/packages/python-xyz.scm       | 113 ++++++++++++++++
 5 files changed, 351 insertions(+), 4 deletions(-)
 create mode 100644 gnu/packages/orange.scm

Comments

Leo Famulari April 23, 2021, 7:29 p.m. UTC | #1
On Fri, Apr 23, 2021 at 05:25:47PM +0000, Vinicius Monego wrote:
> This patchset adds the Orange data mining / data visualization / machine learning toolkit.
> 
> I had to disable tests for the orange widget base because unittest failed to load a file. But all tests for orange itself are passing.
> 
> Vinicius Monego (10):
>   gnu: Add python-anyqt.
>   gnu: Add python-pyqtgraph.
>   gnu: Add python-qasync.
>   gnu: Add python-orange-canvas-core.
>   gnu: Add python-orange-widget-base.
>   gnu: Add python-serverfiles.
>   gnu: Add python-python-louvain.
>   gnu: python-pynndescent: Update to 0.5.2.
>   gnu: python-opentsne: Update to 0.5.2.
>   gnu: Add orange.

Thanks! I sent some comments.

Otherwise, the patches look good to me, based on these standard
assumptions:

1) You linted and built the packages
2) The packages are using the latest upstream versions
3) You checked that the licenses are correct
Vinicius Monego April 23, 2021, 9:20 p.m. UTC | #2
Leo Famulari writes:

> On Fri, Apr 23, 2021 at 05:25:47PM +0000, Vinicius Monego wrote:
>> This patchset adds the Orange data mining / data visualization / machine learning toolkit.
>> 
>> I had to disable tests for the orange widget base because unittest failed to load a file. But all tests for orange itself are passing.
>> 
>> Vinicius Monego (10):
>>   gnu: Add python-anyqt.
>>   gnu: Add python-pyqtgraph.
>>   gnu: Add python-qasync.
>>   gnu: Add python-orange-canvas-core.
>>   gnu: Add python-orange-widget-base.
>>   gnu: Add python-serverfiles.
>>   gnu: Add python-python-louvain.
>>   gnu: python-pynndescent: Update to 0.5.2.
>>   gnu: python-opentsne: Update to 0.5.2.
>>   gnu: Add orange.
>
> Thanks! I sent some comments.
>
> Otherwise, the patches look good to me, based on these standard
> assumptions:
>
> 1) You linted and built the packages
> 2) The packages are using the latest upstream versions
> 3) You checked that the licenses are correct

Thanks for the reminder. I spotted some issues.

- python-setuptools can be removed from the inputs of
  python-orange-canvas-core. The linter will also complain about
  python-docutils being propagated, but that is how it should be.
- python-qasync's license is bsd-2, not bsd-3.
- httpx doesn't need version substitution in orange (already commented
in the other reply).

Orange also states in the website that "non-code" parts are licensed
under CC-BY-SA (version not specified), if that's relevant:

https://orangedatamining.com/license/

All versions are up to date and all packages were built.

Should I send a v2 only for the affected patches?
Leo Famulari April 23, 2021, 9:46 p.m. UTC | #3
On Fri, Apr 23, 2021 at 09:20:08PM +0000, Vinicius Monego wrote:
> Should I send a v2 only for the affected patches?

Can you send the full patch series as v2?

If that's not convenient, I can pick between v1 and v2.