diff mbox series

[bug#47976,05/10] gnu: Add python-orange-widget-base.

Message ID 20210423172816.73579-5-monego@posteo.net
State Accepted
Headers show
Series Add Orange | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego April 23, 2021, 5:28 p.m. UTC
* gnu/packages/orange.scm (python-orange-widget-base): New variable.
---
 gnu/packages/orange.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Leo Famulari April 23, 2021, 7:20 p.m. UTC | #1
On Fri, Apr 23, 2021 at 05:28:11PM +0000, Vinicius Monego wrote:
> * gnu/packages/orange.scm (python-orange-widget-base): New variable.

> +     `(;; unittest fails to load one test, all other tests are passing:
> +       ;; AttributeError: module 'orangewidget' has no attribute 'version'.
> +       #:tests? #f

Sometimes I see this similar errors caused by removal of the ".git"
metadata repository. The build scripts try to use Git to check the
version and fail. Anyways, it's not a big deal.
diff mbox series

Patch

diff --git a/gnu/packages/orange.scm b/gnu/packages/orange.scm
index 9f30befde2..1788163721 100644
--- a/gnu/packages/orange.scm
+++ b/gnu/packages/orange.scm
@@ -65,3 +65,38 @@ 
 for editing workflows.  It is a component used to build the Orange Canvas
 data-mining application.")
     (license license:gpl3+)))
+
+(define-public python-orange-widget-base
+  (package
+    (name "python-orange-widget-base")
+    (version "4.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "orange-widget-base" version))
+       (sha256
+        (base32 "13sy3s8rdqs3i3ghixljpqvnfz81qmbb0kqlasw39zvf39qc22kz"))))
+    (build-system python-build-system)
+    (arguments
+     `(;; unittest fails to load one test, all other tests are passing:
+       ;; AttributeError: module 'orangewidget' has no attribute 'version'.
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _
+             (setenv "HOME" "/tmp")
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
+    (propagated-inputs
+     `(("python-anyqt" ,python-anyqt)
+       ("python-matplotlib" ,python-matplotlib)
+       ("python-orange-canvas-core"
+        ,python-orange-canvas-core)
+       ("python-pyqtgraph" ,python-pyqtgraph)))
+    (home-page "https://github.com/biolab/orange-widget-base")
+    (synopsis "Base Widget for Orange Canvas")
+    (description
+     "Orange Widget Base provides a base widget component for a interactive
+GUI based workflow.  It is primarily used in the Orange framework.")
+    (license license:gpl3+)))