diff mbox series

[bug#47976,04/10] gnu: Add python-orange-canvas-core.

Message ID 20210423172816.73579-4-monego@posteo.net
State Accepted
Headers show
Series Add Orange | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego April 23, 2021, 5:28 p.m. UTC
* gnu/packages/orange.scm: New file.
* gnu/packages/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk            |  1 +
 gnu/packages/orange.scm | 67 +++++++++++++++++++++++++++++++++++++++++
 2 files changed, 68 insertions(+)
 create mode 100644 gnu/packages/orange.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 50b11a8ca2..e8b6effb36 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -420,6 +420,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/openldap.scm			\
   %D%/packages/openpgp.scm			\
   %D%/packages/openstack.scm			\
+  %D%/packages/orange.scm			\
   %D%/packages/orpheus.scm			\
   %D%/packages/ots.scm				\
   %D%/packages/package-management.scm		\
diff --git a/gnu/packages/orange.scm b/gnu/packages/orange.scm
new file mode 100644
index 0000000000..9f30befde2
--- /dev/null
+++ b/gnu/packages/orange.scm
@@ -0,0 +1,67 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages orange)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system python)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt))
+
+(define-public python-orange-canvas-core
+  (package
+    (name "python-orange-canvas-core")
+    (version "0.1.19")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "orange-canvas-core" version))
+       (sha256
+        (base32 "03wav2msfm32y8zwq69v1v6qyh1ld76xla2z60avf49yhbwjgwal"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _
+             ;; This test fails with: RuntimeError: Event loop is closed.
+             (substitute* "orangecanvas/application/tests/test_mainwindow.py"
+               (("test_help_requests") "_test_help_requests"))
+             (setenv "HOME" "/tmp")
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
+    (propagated-inputs
+     `(("python-anyqt" ,python-anyqt)
+       ("python-cachecontrol" ,python-cachecontrol)
+       ("python-commonmark" ,python-commonmark)
+       ("python-dictdiffer" ,python-dictdiffer)
+       ("python-docutils" ,python-docutils)
+       ("python-pyqt" ,python-pyqt)
+       ("python-qasync" ,python-qasync)
+       ("python-requests" ,python-requests)
+       ("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/biolab/orange-canvas-core")
+    (synopsis "Core component of Orange Canvas")
+    (description
+     "Orange Canvas Core is a framework for building graphical user interfaces
+for editing workflows.  It is a component used to build the Orange Canvas
+data-mining application.")
+    (license license:gpl3+)))