diff mbox series

[bug#47769,3/6] gnu: Added go-github-com-caarlos0-spin.

Message ID 20210414102010.6100-3-mjbecze@riseup.net
State New
Headers show
Series Add wally-cli | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Martin Becze April 14, 2021, 10:20 a.m. UTC
* gnu/packages/golang.scm (go-github-com-caarlos0-spin): New variable.
---
 gnu/packages/golang.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Nicolò Balzarotti April 14, 2021, 9:55 p.m. UTC | #1
Hi! I had the wally-cli patch floating around, but did not submit it
because of this package

Martin Becze <mjbecze@riseup.net> writes:

> * gnu/packages/golang.scm (go-github-com-caarlos0-spin): New variable.
> ---
> +    (license license:expat)))
> +

I cannot find the license in the repo, I opened an issue with no
response
https://github.com/caarlos0-graveyard/spin/issues/8

How do you know it's expat?
Martin Becze April 15, 2021, 12:59 p.m. UTC | #2
uff go catch. I think I put that in there for a place holder and forgot 
about it. Not sure what to do here. B/c the code looks pretty abandoned.

On 4/14/21 4:55 PM, Nicolò Balzarotti wrote:
> 
> Hi! I had the wally-cli patch floating around, but did not submit it
> because of this package
> 
> Martin Becze <mjbecze@riseup.net> writes:
> 
>> * gnu/packages/golang.scm (go-github-com-caarlos0-spin): New variable.
>> ---
>> +    (license license:expat)))
>> +
> 
> I cannot find the license in the repo, I opened an issue with no
> response
> https://github.com/caarlos0-graveyard/spin/issues/8
> 
> How do you know it's expat?
>
Nicolò Balzarotti April 15, 2021, 2:57 p.m. UTC | #3
Martin Becze <mjbecze@riseup.net> writes:

> uff go catch. I think I put that in there for a place holder and forgot 
> about it. Not sure what to do here. B/c the code looks pretty abandoned.
I told upstream about the problem here[fn:1] let's see

[fn:1] https://github.com/zsa/wally-cli/pull/7
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3c9698f887..05bec7ea3c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6757,6 +6757,27 @@  compressed streams in Go.")
 supports Printf/Sprintf etc.")
     (license license:unlicense)))
 
+(define-public go-github-com-caarlos0-spin
+  (package
+    (name "go-github-com-caarlos0-spin")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/caarlos0-graveyard/spin.git")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1pnijds4145j8nsxvq8203r2sg2pbk7x8prkdg2ilghhrzqj6vyc"))
+       (file-name (git-file-name name version))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/caarlos0/spin"))
+    (home-page "https://github.com/caarlos0-graveyard/spin")
+    (synopsis "Simple spinner for cli apps")
+    (description "A very simple spinner for cli golang apps.")
+    (license license:expat)))
+
 (define-public go-github-com-songmu-gitconfig
   (package
     (name "go-github-com-songmu-gitconfig")