diff mbox series

[bug#47769,6/6] gnu: Added wally-cli.

Message ID 20210414102010.6100-6-mjbecze@riseup.net
State New
Headers show
Series Add wally-cli | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Martin Becze April 14, 2021, 10:20 a.m. UTC
* gnu/packages/flashing-tools.scm (wally-cli): New variable.
---
 gnu/packages/flashing-tools.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

M April 14, 2021, 9:28 p.m. UTC | #1
On Wed, 2021-04-14 at 05:20 -0500, Martin Becze wrote:
> [...]
> +(define-public wally-cli
> +  (package
> +    (name "wally-cli")
> +    (version "2.0.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/zsa/wally-cli.git")
> +             (commit (string-append version "-linux"))))
> +       (sha256
> +        (base32
> +         "0xz3z18bbnf736ngjj6jhnp3p2j55m5jhnb2xl6l5hybracfyhm7"))
> +       (file-name (git-file-name name version))))
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:tests? #f                      ; tests fail on the linter

Does upstream know about the failing tests?
Also, consider disabling *only* the known failing tests.

Greetings,
Maxime.
Nicolò Balzarotti April 14, 2021, 10:02 p.m. UTC | #2
Maxime Devos <maximedevos@telenet.be> writes:

> On Wed, 2021-04-14 at 05:20 -0500, Martin Becze wrote:
>> [...]
>> +(define-public wally-cli
>> +  (package
>> +    (name "wally-cli")
>> +    (version "2.0.0")
>> +    (source
>> +     (origin
>> +       (method git-fetch)
>> +       (uri (git-reference
>> +             (url "https://github.com/zsa/wally-cli.git")
>> +             (commit (string-append version "-linux"))))
>> +       (sha256
>> +        (base32
>> +         "0xz3z18bbnf736ngjj6jhnp3p2j55m5jhnb2xl6l5hybracfyhm7"))
>> +       (file-name (git-file-name name version))))
>> +    (build-system go-build-system)
>> +    (arguments
>> +     '(#:tests? #f                      ; tests fail on the linter
>
> Does upstream know about the failing tests?
> Also, consider disabling *only* the known failing tests.

@Martin
I had a patch floating around using this commit:
0cf3dd904c5d67278d04182debb310c370754da6
where I commented that this fixed the tests.
Could you check?  Maybe we can ask upstream if they can tag a new
version.

Thanks, Nicolò
Martin Becze April 15, 2021, 1:11 p.m. UTC | #3
Just checked and it works! +1. Nicolo, is your patch on this list?

On 4/14/21 5:02 PM, Nicolò Balzarotti wrote:
> Maxime Devos <maximedevos@telenet.be> writes:
> 
>> On Wed, 2021-04-14 at 05:20 -0500, Martin Becze wrote:
>>> [...]
>>> +(define-public wally-cli
>>> +  (package
>>> +    (name "wally-cli")
>>> +    (version "2.0.0")
>>> +    (source
>>> +     (origin
>>> +       (method git-fetch)
>>> +       (uri (git-reference
>>> +             (url "https://github.com/zsa/wally-cli.git")
>>> +             (commit (string-append version "-linux"))))
>>> +       (sha256
>>> +        (base32
>>> +         "0xz3z18bbnf736ngjj6jhnp3p2j55m5jhnb2xl6l5hybracfyhm7"))
>>> +       (file-name (git-file-name name version))))
>>> +    (build-system go-build-system)
>>> +    (arguments
>>> +     '(#:tests? #f                      ; tests fail on the linter
>>
>> Does upstream know about the failing tests?
>> Also, consider disabling *only* the known failing tests.
> 
> @Martin
> I had a patch floating around using this commit:
> 0cf3dd904c5d67278d04182debb310c370754da6
> where I commented that this fixed the tests.
> Could you check?  Maybe we can ask upstream if they can tag a new
> version.
> 
> Thanks, Nicolò
>
Nicolò Balzarotti April 15, 2021, 1:44 p.m. UTC | #4
Martin Becze <mjbecze@riseup.net> writes:

> Just checked and it works! +1. Nicolo, is your patch on this list?
>
Nope, I was waiting for carlos0 to answer to my licensing issue.
diff mbox series

Patch

diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 4b597dca50..baf9af8715 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021 Martin Becze <mjbecze@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,6 +33,7 @@ 
   #:use-module (gnu packages)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system go)
   #:use-module (guix build-system python)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages admin)
@@ -44,6 +46,7 @@ 
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages groff)
+  #:use-module (gnu packages golang)
   #:use-module (gnu packages pciutils)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages libusb)
@@ -517,3 +520,32 @@  Unifinished Extensible Firmware Interface (UEFI) images.")
 manipulating EPROM load files.  It reads and writes numerous EPROM file
 formats, and can perform many different manipulations.")
     (license license:gpl3+)))
+
+(define-public wally-cli
+  (package
+    (name "wally-cli")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/zsa/wally-cli.git")
+             (commit (string-append version "-linux"))))
+       (sha256
+        (base32
+         "0xz3z18bbnf736ngjj6jhnp3p2j55m5jhnb2xl6l5hybracfyhm7"))
+       (file-name (git-file-name name version))))
+    (build-system go-build-system)
+    (arguments
+     '(#:tests? #f                      ; tests fail on the linter
+       #:import-path "github.com/zsa/wally-cli"))
+    (native-inputs
+     `(("go-gopkg-in-cheggaaa-pb-v1" ,go-gopkg-in-cheggaaa-pb-v1)
+       ("go-github-com-google-gousb" ,go-github-com-google-gousb)
+       ("go-github-com-marcinbor85-gohex" ,go-github-com-marcinbor85-gohex)
+       ("go-github-com-caarlos0-spin" ,go-github-com-caarlos0-spin)
+       ("go-github-com-logrusorgru-aurora" ,go-github-com-logrusorgru-aurora)))
+    (home-page "https://ergodox-ez.com/pages/wally")
+    (synopsis "Flashing tool for ZSA keyboards")
+    (description "This tool is for flashing custom layouts to ZSA keyboards.")
+    (license license:expat)))