diff mbox series

[bug#45000,8/9] gnu: Add ghc-boot-th.

Message ID 20201202045540.31248-8-jonathan@terracrypt.net
State New
Headers show
Series Build git-annex with assistant webapp enabled | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jonathan Frederickson Dec. 2, 2020, 4:55 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-boot-th): New variable.
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a486f5cd59..aa52b69540 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15528,3 +15528,29 @@  and other syntactic elements, without changing the semantics.")
 Haskell source code using Template Haskell.  See
 <http://www.haskell.org/haskellwiki/Template_Haskell> for more information.")
     (license license:bsd-3)))
+
+(define-public ghc-boot-th
+  (package
+    (name "ghc-boot-th")
+    (version "8.10.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/ghc-boot-th/ghc-boot-th-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0vhhmsd32p7zn9vhpv4d0k0b55n2dyhzy42xblndrma617kz8gli"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://hackage.haskell.org/package/ghc-boot-th")
+    (synopsis
+     "Shared functionality between GHC and the `template-haskell` library")
+    (description
+     "This library contains various bits shared between the ghc and
+template-haskell libraries.  This package exists to ensure that
+template-haskell has a minimal set of transitive dependencies, since it is
+intended to be depended upon by user code.")
+    (license license:bsd-3)))