diff mbox series

[bug#45000,6/9] gnu: Add ghc-hjsmin.

Message ID 20201202045540.31248-6-jonathan@terracrypt.net
State New
Headers show
Series Build git-annex with assistant webapp enabled | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jonathan Frederickson Dec. 2, 2020, 4:55 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-hjsmin): New variable.
---
 gnu/packages/haskell-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 19eabd949b..b24c8cf7b7 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15469,3 +15469,36 @@  Zstandard compression algorithm, a fast lossless compression algorithm
 targeting real-time compression scenarios at zlib-level and better
 compression ratios.")
     (license license:bsd-3)))
+
+(define-public ghc-hjsmin
+  (package
+    (name "ghc-hjsmin")
+    (version "0.2.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/hjsmin/hjsmin-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1r2p5rjdjr25j3w4s57q5hxw2c3ymw12x7ms18yvglnq2ivr9fc1"))))
+    (build-system haskell-build-system)
+    (arguments
+    `(#:phases
+       (modify-phases %standard-phases
+         (delete 'check))))
+    (inputs
+     `(("ghc-language-javascript"
+        ,ghc-language-javascript)
+       ("ghc-optparse-applicative"
+        ,ghc-optparse-applicative)))
+    (native-inputs `(("ghc-extra" ,ghc-extra)))
+    (home-page "https://github.com/erikd/hjsmin")
+    (synopsis
+     "Haskell implementation of a javascript minifier")
+    (description
+     "Reduces size of javascript files by stripping out extraneous whitespace
+and other syntactic elements, without changing the semantics.")
+    (license license:bsd-3)))