diff mbox series

[bug#45000,7/9] gnu: Add ghc-template-haskell.

Message ID 20201202045540.31248-7-jonathan@terracrypt.net
State New
Headers show
Series Build git-annex with assistant webapp enabled | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jonathan Frederickson Dec. 2, 2020, 4:55 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-template-haskell): New variable.
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b24c8cf7b7..a486f5cd59 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15502,3 +15502,29 @@  compression ratios.")
      "Reduces size of javascript files by stripping out extraneous whitespace
 and other syntactic elements, without changing the semantics.")
     (license license:bsd-3)))
+
+(define-public ghc-template-haskell
+  (package
+    (name "ghc-template-haskell")
+    (version "2.16.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/template-haskell/template-haskell-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1nk1cv35szp80qkhbyh5gn6vn194zzl0wz186qrqdrdx3a9r9w4g"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-boot-th" ,ghc-boot-th)))
+    (home-page
+     "http://hackage.haskell.org/package/template-haskell")
+    (synopsis "Support library for Template Haskell")
+    (description
+     "This package provides modules containing facilities for manipulating
+Haskell source code using Template Haskell.  See
+<http://www.haskell.org/haskellwiki/Template_Haskell> for more information.")
+    (license license:bsd-3)))