diff mbox series

[bug#45000,4/9] gnu: Add ghc-cryptonite-conduit.

Message ID 20201202045540.31248-4-jonathan@terracrypt.net
State New
Headers show
Series Build git-annex with assistant webapp enabled | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jonathan Frederickson Dec. 2, 2020, 4:55 a.m. UTC
* gnu/packages/haskell-crypto.scm (ghc-cryptonite-conduit): New variable.
---
 gnu/packages/haskell-crypto.scm | 39 +++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index c92dec9932..ec6c643592 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -330,6 +330,45 @@  public key algorithms, key derivation numbers, cryptographic random number
 generators, and more.")
     (license license:bsd-3)))
 
+(define-public ghc-cryptonite-conduit
+  (package
+    (name "ghc-cryptonite-conduit")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/cryptonite-conduit/cryptonite-conduit-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1bldcmda4xh52mw1wfrjljv8crhw3al7v7kv1j0vidvr7ymnjpbh"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-conduit" ,ghc-conduit)
+       ("ghc-conduit-extra" ,ghc-conduit-extra)
+       ("ghc-cryptonite" ,ghc-cryptonite)
+       ("ghc-exceptions" ,ghc-exceptions)
+       ("ghc-memory" ,ghc-memory)
+       ("ghc-resourcet" ,ghc-resourcet)))
+    (native-inputs
+     `(("ghc-conduit-combinators"
+        ,ghc-conduit-combinators)
+       ("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+       ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+    (arguments
+     `(#:cabal-revision
+       ("1"
+        "1hh2nzfz4qpxgivfilgk4ll416lph8b2fdkzpzrmqfjglivydfmz")))
+    (home-page
+     "https://github.com/haskell-crypto/cryptonite-conduit")
+    (synopsis "Conduit bridge for cryptonite")
+    (description
+     "This package provides a simple conduit wrapper for cryptonite hashes")
+    (license license:bsd-3)))
+
 (define-public ghc-digest
   (package
     (name "ghc-digest")